Invalidation issues resizing windows with scaled tiled backgrounds

RESOLVED DUPLICATE of bug 509329

Status

()

P2
normal
RESOLVED DUPLICATE of bug 509329
10 years ago
9 years ago

People

(Reporter: Waldo, Assigned: Waldo)

Tracking

({css3})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
<Waldo> bz: so, I'm seeing hideous artifacts on Windows if I load <http://whereswalden.com/>, then <javascript:document.body.id="experimental";[].v>, then resize the window -- could it be a ireflow problem? I don't remember seeing this on OS X when testing background-size patches
<Waldo> screenshot: http://whereswalden.com/files/temp/artifacts.png (note a few rects with proper rendering showing through where another window in the OS obscured the page at one point)

bz sez doesn't look like ireflow, maybe invalidation, so looks like I get to investigate and determine what's wrong.
(Assignee)

Comment 1

10 years ago
This doesn't reproduce in OS X, hence why I never saw it during my own testing.
(Assignee)

Comment 2

10 years ago
Part of the story appears to be nsFrame::CheckInvalidateSizeChange.  If I breakpoint in that when resizing the window, I get the interesting result that aOldRect has zero height and apparently-reasonable width.  Of course, invalidating that (with a tweak to the background loop in that method, to accommodate contain/cover) doesn't have much effect, and if I hop up a couple levels in the stack I don't see anything in nsBlockFrame::Reflow that invalidates anything else in view (assuming that you start with about:blank following the instructions in comment 0).  The method has comments that claim aNewDesiredSize - aOldRect should have been invalidated elsewhere, but I don't see where that would happen.
(Assignee)

Updated

10 years ago
Flags: blocking1.9.2?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
(Assignee)

Comment 4

9 years ago
(As I noted in bug 509329 I plan to get to this next week.)
(Assignee)

Comment 5

9 years ago
Created attachment 407904 [details]
Reduced testcase

Here's a testcase reduced from the original errors.  With respect to the proto-patch in bug 509329, two bits are important: first, it's a fixed background, and second, the body has a width.  Remove those, or the latter, and with that first patch there this testcase will work correctly.
(Assignee)

Comment 6

9 years ago
This bug is cross-platform; its visibility seems to depend on the frequency of OS-level whole-window invalidates.  OS X invalidates often enough that this never shows up there, but Linux and Windows are more judicious and thus demonstrate problems during (and for Windows, after) window resizing.
OS: Windows XP → All
Hardware: x86 → All
Summary: Invalidation (?) issues resizing windows with scaled tiled backgrounds in Windows → Invalidation issues resizing windows with scaled tiled backgrounds
(Assignee)

Comment 7

9 years ago
Fixed in bug 509329.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509329
You need to log in before you can comment on or make changes to this bug.