some images in the UI and on web pages are being rendered in greyscale on Ubuntu 9.04 (possibly limited to PNGs)

RESOLVED WONTFIX

Status

()

Core
GFX: Color Management
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: Macha, Unassigned)

Tracking

1.9.1 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

The newest firefox build available in the ubuntu repos was 3.5 RC2, so I downloaded 3.5.1 from mozilla.com and extracted it to a folder on my desktop.

Then I changed my firefox shortcuts from /usr/bin/firefox %u to /home/me/Desktop/firefox/firefox %u .

Since doing this, some images (both parts of the UI, and images on web pages) are being rendered in greyscale. All the images in web pages affected are PNGs, but not all PNGs are affected.



Reproducible: Always

Steps to Reproduce:
1. Go to site linked as an example.
2. Look at the images.
Actual Results:  
The logo up in the top left (a PNG) is fine for me, but the screenshot (also showing the problem in action, in case your browser renders it fine) I posted is all in greyscale when viewed with 3.5.1 (it's fine in RC2, other browsers

Expected Results:  
Should the images with the correct colours.

Firefox is using the default theme.

Disabling plugins does not fix the issue.

My computer Ubuntu 9.04 with both GNOME and KDE installed (GNOME is the default desktop).
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch

Comment 1

8 years ago
Do you refer to the cc-by-sa image - and the other logo in the bottom right?
This image is greyscale.
Also - the site indicates it's in private beta - and has no other images - other than the toolbar links - do you perhaps have a login to this site?
Can you show it on another site?
Does it work if you change gfx.color_management.mode from 2 to 0 in about:config ?
(Reporter)

Comment 3

8 years ago
@Ian: Sorry I forgot, beta password is at the offical blog http://blog.stackoverflow.com/2009/07/super-user-semi-private-beta-begins/.

It's ewok.adventure (it's posted publicly officially, so there's no harm posting it here).

The image in the thread is what I referred to (which you will see if you type in ewok.adventure).

As for another site: The favicon for this site (bugzilla itself) is also being greyed out.

Link to an image showing it going wrong: http://imgkk.com/i/I1v0LZ.png
(Reporter)

Comment 4

8 years ago
@matti

I've changed the setting, and restarted firefox, and it still looks the same.
(Reporter)

Comment 5

8 years ago
Update: It appears last time I restarted firefox, it was still running on another desktop, so it wasn't a proper restart. Now (with the settings changed), it is appearing correctly.
Firefox3.5 does Color correction for images with a color profile by default.
This looks like an issue with your used color profile/X server.
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Version: 3.5 Branch → 1.9.1 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.