Closed Bug 507896 Opened 10 years ago Closed 8 years ago

Upgrading Seamonkey changes file type icon for HTML files to mail

Categories

(SeaMonkey :: Installer, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b2

People

(Reporter: 3.14, Assigned: mcsmurf)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

After (automatic) upgrading from alpha to Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1 in Windows Vista all HTML files (including .html, .htm, .shtml) are displayed with the SeaMonkey mail icon (the envelope with the down arrow).

I tried to reassign those file types to IE (which worked showing the IE icon). Then reassigned to SeaMonkey. Again wrong icon.

It was correct before the upgrade.

pi
Flags: blocking-seamonkey2.0b2?
Do you happen to know the file name of the icon? Or can you post a screen shot of the icon? The only arrow down icon I can remember atm is http://mxr.mozilla.org/comm-central/source/suite/branding/icons/windows/downloadManager.ico
It is the second icon included in seamonkey.exe. Screenshot follows.

pi
seamonkey.exe does not include that icon, seamonkey.exe only has one embedded icon, the logo itself (you can check this by creating a shortcut to seamonkey.exe and clicking on "Anderes Symbol..." in the properties of the shortcut).
Maybe there is something wrong with Windows' icon cache. AFAIR XP did have such a cache and this could have caused such troubles.

Actually I'm not on Windows and I hardly know anything about Vista.
Frank, this is exactly, what I did. I receive three icons to choose from: the SeaMonkey in the blue circle, the envelope and again the first icon.

pi
Jürgen, good idea. Yet not successful. I deleted the IconCache.db, restarted the system, but nothing changed.

pi
Looks like the icon was added in Bug 389448.
Not sure though why it chooses that one as icon. Can you check in the registry what value HKEY_CLASSES_ROOT\SeaMonkeyHTML\DefaultIcon is set to?
It is set to "C:\Program Files\SeaMonkey\chrome\icons\default\html-file.ico". That would be correct. Yet this is not what is used.

pi
Yes, this is a regression. Would be useful to try and narrow the regression window.
Flags: blocking-seamonkey2.0b2? → blocking-seamonkey2.0b2+
Should fix this problem, although I'm not really sure. But it certainly fixes a bug in the code that might cause this bug here.
Assignee: installer → bugzilla
Attachment #397539 - Flags: review?(bugzilla)
Attachment #397539 - Flags: review?(bugzilla) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/e7c2a5448c9e
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b2
Upgrading to Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091007 SeaMonkey/2.0 changes the problem. Now for .html files a white sheet of paper is used as the icon.

pi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can you check what value HKEY_CLASSES_ROOT\SeaMonkeyHTML\DefaultIcon has in the registry? Can you also check if the key HKEY_LOCAL_MACHINE\Software\Classes\SeaMonkeyHTML\ShellEx\IconHandler exists? If it does exist, please check what value the key HKEY_LOCAL_MACHINE\Software\CLSID\[value of the IconHandler key]\Old Icon\SeaMonkeyHTML\DefaultIcon is set to and post all the values to this bug here.
Sure.

HKEY_CLASSES_ROOT\SeaMonkeyHTML\DefaultIcon: C:\Program Files\SeaMonkey\chrome\icons\default\html-file.ico (this actually is the icon I would expect)

HKEY_LOCAL_MACHINE\Software\Classes\SeaMonkeyHTML\ShellEx\IconHandler has value {42042206-2D85-11D3-8CFF-005004838597}

HKEY_LOCAL_MACHINE\Software\CLSID does not exist. Did you mean HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{42042206-2D85-11D3-8CFF-005004838597}\Old Icon\SeaMonkeyHTML\DefaultIcon? It has value C:\Program Files\SeaMonkey\chrome\icons\default\html-file.ico

HTML files (as shown in Windows Explorer) habe file type SeaMonkey Document, yet show a white sheet of paper logo.

pi
This bug is open but targeted for seamonkey2.0b2, which has been released a significant time ago. Please set the target milestone to an appropriate value, "---" if it has no specific target.
Flags: wanted-seamonkey2.1?
Resetting target milestone for now, will try to find the cause of this bug.
Target Milestone: seamonkey2.0b2 → ---
Flags: wanted-seamonkey2.1?
mcsmurf, Boris

Have either of you spent any additional time on this; is it still a problem? Initial Patch has landed, however no recent progress. We are nearing beta for 2.1 and it would be useful to get this accomplished for at least that release if it is still an issue.

...in-fact since this was a blocking+ bug from a while ago, and landed for 2.0b2, I'm resolving fixed and setting the t-m correctly. NEW BUG PLEASE if this is still an issue, so we can triage/track it correctly.
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b2
I tried to find what is causing this bug, but then I was unable to reproduce the bug :( iirc third party software was involved..
I still have the issue. No third party I am aware of involved.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #397539 - Attachment description: Patch → Patch [Checked in: Comment 12]
Depends on: 716234
(In reply to Justin Wood (:Callek) from comment #18)
> NEW BUG PLEASE if
> this is still an issue, so we can triage/track it correctly.

Bug 716234.

(In reply to Frank Wein [:mcsmurf] from comment #19)
> I tried to find what is causing this bug, but then I was unable to reproduce
> the bug :( iirc third party software was involved..

Please, don't reopen this bug.
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.