Closed Bug 507928 Opened 13 years ago Closed 10 years ago

Firefox crashes upon loading page with chatbox widgets [@nsBaseWidget::Destroy() ]

Categories

(Core :: Plug-ins, defect, P2)

1.9.1 Branch
x86
Windows XP
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: darkzamach, Assigned: jst)

References

()

Details

(Keywords: crash, topcrash, Whiteboard: [crashkill])

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

When loading the page, sometimes upon loading the sidebar it seems to get stuck, usually it shows that its loading the chatbox on the page. It then just closes down everything.

Reproducible: Sometimes

Steps to Reproduce:
1. Just browsing the page
2.
3.
Actual Results:  
On some occasions it allows me to browse normally but usually within a few clicks it crashes firefox

Expected Results:  
Allow the page to fully load

Have tried replacing the chatbox code by installing other boxes, have tried reinstalling firefox. The problem only recently started, where there has been no software or hardware changes.

http://crash-stats.mozilla.com/report/index/2c015917-8919-43ef-805c-a73e42090802?p=1



Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a97db942191c
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --with-crashreporter-enable-percent=10
Severity: normal → critical
Component: Tabbed Browser → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: tabbed.browser → plugins
Version: unspecified → 1.9.1 Branch
0  	xul.dll  	nsBaseWidget::Destroy  	 widget/src/xpwidgets/nsBaseWidget.cpp:257
1 	xul.dll 	nsWindow::Destroy 	widget/src/windows/nsWindow.cpp:1532
2 	xul.dll 	nsPluginInstanceOwner::Destroy 	layout/generic/nsObjectFrame.cpp:4066
3 	xul.dll 	DoStopPlugin 	layout/generic/nsObjectFrame.cpp:1983
4 	xul.dll 	nsStopPluginRunnable::Run 	layout/generic/nsObjectFrame.cpp:2020
5 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
6 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
7 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
8 	nspr4.dll 	PR_GetEnv 	
9 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
10 	firefox.exe 	firefox.exe@0x21a7 	
11 	kernel32.dll 	BaseProcessStart

could be related to bug 470487
Summary: Firefox crashes upon loading page with chatbox widgets → Firefox crashes upon loading page with chatbox widgets [@nsBaseWidget::Destroy() ]
Blocking 1.9.2+ per CrashKill effort.  Assigning to JST to find an owner.  Johnny?
Assignee: nobody → jst
Flags: blocking1.9.2+
Marking all topcrash bugs as P2 (3.6 release blockers, but not 3.6b1 blockers)
Priority: -- → P2
Keywords: topcrash
Whiteboard: [crashkill]
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 526787
Unblocking 1.9.2 on this as this is only a problem on 1.9.1.
Flags: blocking1.9.2+ → blocking1.9.2-
Crash Signature: [@nsBaseWidget::Destroy() ]
All of these crashes appear in 3.5 only. There is a single crash appearing in 9.0b2 but no other current versions. We assume this is something different and are going to track separately. Resolving as works for me for this particular bug.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.