table cell bg color doesn't work the first time.

VERIFIED FIXED in mozilla0.9.1

Status

()

defect
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: sujay, Assigned: rubydoo123)

Tracking

({helpwanted, perf})

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: relnote-user)

(Reporter)

Description

19 years ago
using 8/30 build of netscape

1) launch netscape
2) launch composer
3) insert default table
4) click in one of the cells
5) pull down Table | Tableor cell background color
6) pick a colore
7) click OK

notice you don't see the table cell color change...

it somehow works the second or third time...



all platforms.
(Assignee)

Comment 1

19 years ago
actually, the color is visible when you type a character, something needs to 
trigger the cell to change and the character entry does that.

moving this out to future
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

19 years ago
This isn't the only circumstance when changing a cell or color table color
doesn't trigger repaint. It sucks!
Maybe we can address this issue when we do "performance" work, which would
seem to involve examining the incremental painting code?
CCing Marc, since he is expert with similar problems in the past.
(Assignee)

Comment 3

19 years ago
I agree this is awful, I will reset to perf work and set it to m19
Keywords: relnoteRTMperf, relnote3
Target Milestone: Future → M19

Comment 4

19 years ago
The color of the cell is changing immediatly for me on today's build - did it 
get fixed, or is it tempermental? I tried both menu choices:
Table | Table or Cell Background Colors... and 
Format | Table Cell Properties
(Assignee)

Comment 5

19 years ago
Marc, it's still there, try this
1.insert default table
2.insert 4-5 lines of text in upper left cell
3.select all text and align right
4.set caret to the left of the first character in the first line
5.select a background color

only part of the cell fills, you must do something at this point for the rest of 
the cell to fill, it happens in other cases too -- this is just the easist to 
dup
(Assignee)

Comment 6

19 years ago
reviewed by Bijal and beppe, setting to future
Keywords: relnoteRTM
Target Milestone: M19 → Future

Comment 7

19 years ago
Is this a duplicate of 53741? Both have the relnote3 keyword.
Whiteboard: relnote-user

Comment 8

19 years ago
cc'ng myself

Comment 9

18 years ago
This seems to be fixed already. I tried sujay's original problem, and beppe's 
problem, and both seem to work ok now.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Target Milestone: Future → mozilla0.9.1
(Reporter)

Comment 10

18 years ago
verified in 4/19 build.
Status: RESOLVED → VERIFIED
Jatin -- another one that was release noted that, if it's still in that doc, will 
need to come out when you do the next draft
You need to log in before you can comment on or make changes to this bug.