[SeaMonkey 2.1] Location bar autocomplete doesn't work anymore

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Autocomplete
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

({fixed-seamonkey2.0, regression})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0, regression
Dependency tree / graph
Bug Flags:
in-testsuite -
blocking-seamonkey2.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.3pre) Gecko/20090803 SeaMonkey/2.0b2pre] (comm-1.9.1-win32/1249316053) (W2Ksp4)
(http://hg.mozilla.org/releases/mozilla-1.9.1/rev/0cd4042314d4
 +http://hg.mozilla.org/comm-central/rev/...)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090725 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/b8c752d9bc65
 +http://hg.mozilla.org/comm-central/rev/413ab70abcfb + bug 467356 patch Bv1)

Work fine.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090802 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/3ae688630837
 +http://hg.mozilla.org/comm-central/rev/87e1c230dc9c)

Doesn't work and reports
{
Error: uncaught exception: [Exception... "'[JavaScript Error: "this._pendingQuery is undefined" {file: "file:///.../components/nsPlacesAutoComplete.js" line: 635}]' when calling method: [nsIAutoCompleteSearch::stopSearch]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/autocomplete.xml :: anonymous :: line 322"  data: yes]
}


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090803 SeaMonkey/2.1a1pre] (comm-central-trunk-win32/1249315252) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/97ec2484a49a
 +http://hg.mozilla.org/comm-central/rev/...)

No more error, but still doesn't work: dropdown does no open.
(Assignee)

Updated

8 years ago
Blocks: 470184
(Assignee)

Comment 1

8 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090730 SeaMonkey/2.1a1pre] (nightly) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/505e5dc1e170
 +http://hg.mozilla.org/comm-central/rev/...)

Still works fine.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090802 SeaMonkey/2.1a1pre] (comm-central-trunk-win32/1249243074) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/990d01d87283
 +http://hg.mozilla.org/comm-central/rev/...)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090803 SeaMonkey/2.1a1pre] (nightly) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/c6692a8f3f27
 +http://hg.mozilla.org/comm-central/rev/...)

Broken with no error.


No other Windows nightly to try.
(3 days) Regression timeframe:
for sure,
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=505e5dc1e170&tochange=990d01d87283
and probably,
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=505e5dc1e170&tochange=3ae688630837

Comment 2

8 years ago
I can confirm this with Linux builds. 
Build identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a2pre) Gecko/20090808 SeaMonkey/2.1a1pre
(Assignee)

Updated

8 years ago
OS: Windows 2000 → All

Comment 3

8 years ago
I suspect part of http://hg.mozilla.org/mozilla-central/log?rev=8cff4bd2121a
to have broken SeaMonkey's location bar. Unfortunately that changeset covers
quite a lot of bugs and their respective patches. :-(

We may have to port the asynchronous location bar in order to fix that bug.
Hardware: x86 → All

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508102
(Assignee)

Comment 5

8 years ago
V.Duplicate, though this bug was filed a few hours before the other one.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
No longer blocks: 470184
(Assignee)

Comment 6

8 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20090912 SeaMonkey/2.1a1pre] (nightly) (W2Ksp4)

Well, bug 508102 was fixed, but this bug is still there :-<
(Assignee)

Updated

8 years ago
Blocks: 470184, 508102
Status: VERIFIED → REOPENED
Flags: blocking-seamonkey2.1a1?
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

8 years ago
(In reply to comment #3)
> We may have to port the asynchronous location bar in order to fix that bug.

Is this what is needed here?
Status: REOPENED → NEW
(Assignee)

Updated

8 years ago
Blocks: 455555
No longer blocks: 508102
Depends on: 508102

Comment 8

8 years ago
It looks like bug 508102 either did not get checked into the SeaMonkey trunk builds (it still fails with a 9/13 build off of comm-central) - or the fix simply doesn't work with the trunk. 

With a 9/13 comm-1.9.1 build everything is fine now, so the branch is okay.

Comment 9

8 years ago
Works for me with trunk-based builds on two different PCs.

Comment 10

8 years ago
It does not work with 20090912 SeaMonkey/2.1a1pre under Windows 7.  (The branch builds work fine.)

Comment 11

8 years ago
Hmm.  I just noticed that the trunk build I'm using is 9/12, not 9/13 as I'd reported in comment 8.  Only the branch build is 9/13.  Maybe it's a date issue - although it should have been checked in on 9/12 too...

Comment 12

8 years ago
Okay, so regular Windows trunk builds have still not been available since 9/12 - but I did manage to download a tinderbox Windows trunk build from today (9/17).  This version still does not work for me under Windows 7.  (And this is on my work PC rather than my home PC where I'd tested earlier.)  Again, though, branch builds now work just fine - so something is still wrong with the trunk only.
(In reply to comment #0)
> Error: uncaught exception: [Exception... "'[JavaScript Error:
> "this._pendingQuery is undefined" {file:
> "file:///.../components/nsPlacesAutoComplete.js" line: 635}]' when calling
> method: [nsIAutoCompleteSearch::stopSearch]"  nsresult: "0x80570021
> (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
> chrome://global/content/autocomplete.xml :: anonymous :: line 322"  data: yes]
Bug 508102 fixed this exception, and my debug build is now working, but I haven't tried installing a tinderbox build.

Comment 14

8 years ago
Looks like the fix for bug 508102 was applied to a branch only and not the trunk
Flags: blocking-seamonkey2.0?

Comment 15

8 years ago
Not blocking 2.0 on a bug that apparently is on 2.1a1pre only.
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0-
(Assignee)

Comment 16

8 years ago
(In reply to comment #14)
> Looks like the fix for bug 508102 was applied to a branch only and not the
> trunk

No, it was pushed to m-c and m-192.

Comment 17

8 years ago
Autocomplete indeed still does not work in the location bar in
Seamonkey2.1a1pre Build ID:{20090924013522} And the discussion of this bug goes
parallel with the discussion of Bug 508102 -  Warning: reference to undefined property this._pendingQuery / Location bar autocomplete doesn't work anymore   Is this how it should be?
Created attachment 403261 [details]
Possibly unpackaged file

After talking to sdwilsh on IRC I think the other cause of the problem is that this component (attached) is not distributed in nightly builds as it should. Perhaps someone could verify that by saving this platform-independent file into their bin/components folder and deleting the compreg.dat file in their profile.

Comment 19

8 years ago
What should the filename be named?
(Assignee)

Comment 20

8 years ago
(In reply to comment #18)
> Created an attachment (id=403261) [details]
> After talking to sdwilsh on IRC I think the other cause of the problem is that
> this component (attached) is not distributed in nightly builds as it should.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20090928 SeaMonkey/2.1a1pre] (nightly) (W2Ksp4)

Works after adding nsPlacesAutoComplete.js from m-c :-)
This file should be packaged "#ifndef 191".


(In reply to comment #19)
> What should the filename be named?

(See attachment filename.)

Comment 21

8 years ago
Confirmed here too.
(Assignee)

Comment 22

8 years ago
Created attachment 404634 [details] [diff] [review]
(Av1) Package nsPlacesAutoComplete.js, Improve sort order
[Checkin: Comment 24]

Just like bug 512005.
Assignee: nobody → sgautherie.bz
Attachment #403261 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #404634 - Flags: review?(kairo)
Attachment #404634 - Flags: approval-seamonkey2.0?
(In reply to comment #19)
> What should the filename be named?
Assuming you're using SeaMonkey 2.1a1pre to download it, even right-click downloading will suggest the correct filename (bug 426742).

Updated

8 years ago
Attachment #404634 - Flags: review?(kairo)
Attachment #404634 - Flags: review+
Attachment #404634 - Flags: approval-seamonkey2.0?
Attachment #404634 - Flags: approval-seamonkey2.0+
(Assignee)

Comment 24

8 years ago
Comment on attachment 404634 [details] [diff] [review]
(Av1) Package nsPlacesAutoComplete.js, Improve sort order
[Checkin: Comment 24]


http://hg.mozilla.org/comm-central/rev/68f19c4f61b4
Attachment #404634 - Attachment description: (Av1) Package nsPlacesAutoComplete.js, Improve sort order → (Av1) Package nsPlacesAutoComplete.js, Improve sort order [Checkin: Comment 24]
(Assignee)

Updated

8 years ago
No longer blocks: 455555
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Depends on: 455555
No longer depends on: 508102
Flags: blocking-seamonkey2.1a1? → in-testsuite-
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
You need to log in before you can comment on or make changes to this bug.