LTR text in RTL textarea may reverse while deleting text

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: tomer, Unassigned)

Tracking

({regression, rtl, verified1.9.1})

unspecified
regression, rtl, verified1.9.1
Points:
---
Bug Flags:
wanted1.9.2 +
in-testsuite ?

Firefox Tracking Flags

(status1.9.2 beta1-fixed, status1.9.1 .6-fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 392542 [details]
testcase

When mixing between LTR and RTL text in a multiple lines textarea, while removing characters the English text can lose its direction and appear reversed in the textbox.

Steps to reproduce (see attached testcase): 
a. Place the text cursor between the two 'a' characters.
b. Press the backspace key until the English text reverse.
c. Press the backspace key again to get the English text to appear correctly again.

Issue is reproducible for me on Firefox 3.5/Gecko 1.9.1, but not on Firefox 3.0/Gecko 1.9.0.
(Reporter)

Comment 1

8 years ago
Created attachment 392543 [details]
screenshot of the testcase
Created attachment 392567 [details]
more reproducable testcase

Specifying the width of the textarea makes this reproducable for me on both Mac and Linux
OS: Linux → All
Hardware: x86 → All
Uh, no. The second testcase only shows the bug on Mac (at least with my fonts)
As it happened I pulled today after bug 504524 was checked in and before it was backed out, and it seems to fix this.
Depends on: 504524
Flags: blocking1.9.2?
Fixed by bug 504524. We need to find a variation on the theme of the attached testcases which will reliably fail without the fix.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Mmmm, do we want to take bug 504524 on branch? I'm not sure.
(In reply to comment #6)
> Mmmm, do we want to take bug 504524 on branch? I'm not sure.

Is that a criterion for whether this is a blocker, or just an obiter dictum? We can probably fix this independently of bug 504524 if necessary.
How hard is it to fix independently?
Because of the serendipity described in comment 4 I never investigated it thoroughly. I would guess that if I invested enough debugging time to answer the question, the actual fix would take much less time. Probably not more than one or two days' work altogether.
Humph, it looks like this is WFM on 1.9.2, though not on 1.9.1. Possibly bug 490559 is enough to fix it.
blocking1.9.1: --- → ?
Flags: blocking1.9.2?
Yes, bug 490559 does fix this.
status1.9.2: --- → beta1-fixed
Depends on: 490559
No longer depends on: 504524
Flags: wanted1.9.2+
Sounds ugly but not really a "blocker". Happily you have already identified the patch so we'll get to that approval request.
blocking1.9.1: ? → ---
status1.9.1: --- → wanted
Keywords: regression
status1.9.1: wanted → .5-fixed
Verified for 1.9.1 with bug 490559.
Keywords: verified1.9.1
You need to log in before you can comment on or make changes to this bug.