Design titles with max allowed character length(62chs) break the format

VERIFIED FIXED in 1.0

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: krupa.mozbugs, Assigned: ryansnyder)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 392604 [details]
lengthy title(with no page break)

steps to reproduce:
1.Upload a design with title=62 chs long

observed behavior:
Page formatting breaks

additional info:
title=62 chs long with one line break also breaks the format(overlap of sections)
(Reporter)

Comment 1

9 years ago
Created attachment 392605 [details]
lengthy title with one page break(section overlap)
(Reporter)

Comment 2

9 years ago
Created attachment 392606 [details]
in the gallery
Assignee: nobody → ryan

Comment 3

9 years ago
Ryan, how easy/hard is it to impose a character limit on design titles?

This isn't a showstopper for launch, but would be nice to have fixed relatively soon.
There's currently a 64 character limit on Design Titles.

This is really only an issue with titles that have 62+ CONSECUTIVE characters.  A title with 64 non-consecutive characters looks like this (and I think it looks fine):
http://mcc.stage.mozilla.com/designs
http://mcc.stage.mozilla.com/designs/117
The addition of overflow:hidden should solve this. Extra-long, non-breaking titles are visually truncated when they hit the edge of their container (the text is still there, it's just cut off).
Marking as resolved.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

9 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.