Last Comment Bug 508452 - update to current spec for canvas ctx.font getter and setter
: update to current spec for canvas ctx.font getter and setter
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: mozilla2.0b3
Assigned To: David Baron :dbaron: ⌚️UTC-10
:
: Milan Sreckovic [:milan]
Mentors:
: 601233 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-04 17:28 PDT by David Baron :dbaron: ⌚️UTC-10
Modified: 2010-10-01 14:07 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
revert (and merge to tip) incorrect changes from bug 523496 (4.38 KB, patch)
2010-06-19 14:59 PDT, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review
patch 2: remove redundant parsing of line-height (1.07 KB, patch)
2010-06-19 15:00 PDT, David Baron :dbaron: ⌚️UTC-10
no flags Details | Diff | Splinter Review
patch 3: implement the spec updates (6.56 KB, patch)
2010-06-19 15:01 PDT, David Baron :dbaron: ⌚️UTC-10
no flags Details | Diff | Splinter Review
implement the spec updates (5.22 KB, patch)
2010-06-19 15:22 PDT, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-10 2009-08-04 17:28:09 PDT
Hixie recently made some changes to the spec for the ctx.font getter and setter; I have a work in progress patch to implement them at http://hg.mozilla.org/users/dbaron_mozilla.com/patches/file/tip/ctx-font-updates but I still need to write tests (and make sure the patch passes them).
Comment 1 David Baron :dbaron: ⌚️UTC-10 2009-08-04 17:32:05 PDT
I realize my current patch doesn't work for system fonts, though.
Comment 2 John Daggett (:jtd) 2009-08-07 00:44:27 PDT
Is there a reference to a spec?
Comment 4 David Baron :dbaron: ⌚️UTC-10 2009-08-20 07:26:48 PDT
I also wonder if I should be editing our canvas tests directly or if there's a source form for them that's not in our tree that I should be editing instead.
Comment 5 David Baron :dbaron: ⌚️UTC-10 2010-03-08 20:39:14 PST
http://philip.html5.org/tests/canvas/suite/tests/ may be the source of the tests; I need to investigate further to see if there's something there that puts them in the form we have.
Comment 6 David Baron :dbaron: ⌚️UTC-10 2010-06-19 14:59:54 PDT
Created attachment 452494 [details] [diff] [review]
revert (and merge to tip) incorrect changes from bug 523496
Comment 7 David Baron :dbaron: ⌚️UTC-10 2010-06-19 15:00:45 PDT
Created attachment 452495 [details] [diff] [review]
patch 2: remove redundant parsing of line-height

Parsing the 'font' shorthand is sufficient.
Comment 8 David Baron :dbaron: ⌚️UTC-10 2010-06-19 15:01:43 PDT
Created attachment 452496 [details] [diff] [review]
patch 3: implement the spec updates

... though, honestly, I'm a little skeptical, because each time I think about posting this patch, it turns out that the spec has changed again.
Comment 9 David Baron :dbaron: ⌚️UTC-10 2010-06-19 15:03:52 PDT
Comment on attachment 452496 [details] [diff] [review]
patch 3: implement the spec updates

Actually, I changed my mind; I can simplify this code a bit now that the requirements changed again.
Comment 10 David Baron :dbaron: ⌚️UTC-10 2010-06-19 15:22:48 PDT
Created attachment 452499 [details] [diff] [review]
implement the spec updates

Simpler version.
Comment 11 Boris Zbarsky [:bz] (still a bit busy) 2010-07-24 00:29:22 PDT
Comment on attachment 452494 [details] [diff] [review]
revert (and merge to tip) incorrect changes from bug 523496

r=bzbarsky
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2010-07-24 00:35:37 PDT
Comment on attachment 452499 [details] [diff] [review]
implement the spec updates

r=bzbarsky
Comment 14 David Baron :dbaron: ⌚️UTC-10 2010-07-24 12:23:52 PDT
er, second link should have been
http://hg.mozilla.org/mozilla-central/rev/555a6f96ec12
Comment 15 Boris Zbarsky [:bz] (still a bit busy) 2010-10-01 14:07:53 PDT
*** Bug 601233 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.