If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CTRL-F5 causes images to be downloaded multiple times

VERIFIED DUPLICATE of bug 497665

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 497665
8 years ago
8 years ago

People

(Reporter: publicpp+mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3pre) Gecko/20090803 Ubuntu/8.10 (intrepid) Shiretoko/3.5.3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3pre) Gecko/20090803 Ubuntu/8.10 (intrepid) Shiretoko/3.5.3pre

Hitting CTRL-F5 causes pages to load slowly because images are loaded many times. If same picture is referenced from 10 places on the page, then it is fetched 10 times.

I've verified it using FireBug Net module and using wireshark to inspect traffic.

Reproducible: Always

Steps to Reproduce:
1. Install FireBug (the bug is reproducible also without FireBug, so it is not FireBug bug)
1. Go to http://wikipedia.org/
2. Enable Net monitoring in FireBug.
3. Hit CTRL-F5.
Actual Results:  
Observe that image: http://upload.wikimedia.org/wikipedia/commons/b/bd/Bookshelf-40x201_6.png is being downloaded more than once.

Expected Results:  
The image http://upload.wikimedia.org/wikipedia/commons/b/bd/Bookshelf-40x201_6.png should be downloaded once, like in Firefox 3.0.

Tested on Linux and Windows versions of FF3.5
Please search before filing a bug, thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497665

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.