Wrong page display in blogs of blog.163.com

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Chinese-Simplified
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: Kemcy BEST, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090804 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090804 Minefield/3.6a1pre

Any blog created on blog.163.com (e.g., http://krugmanblog.blog.163.com ) is broken in Minefield 3.6a1, but it's OK using Firefox 3.5.2 (as well as in IE6.0 and Google Chrome 3). 

Screenshots to be added

Reproducible: Always

Steps to Reproduce:
1. Open http://krugmanblog.blog.163.com/

Actual Results:  
Page not correctly displayed, throbber always shows "loading" (see screenshot)

Expected Results:  
Page displayed as it is in IE 6.0, Firefox 3.5.2 and Google Chrome 3.0.189 (SRWare Iron Edition)

(see screenshot)
(Reporter)

Comment 1

8 years ago
Created attachment 392729 [details]
Wrong display using 3.6a1

Wrong display using 3.6a1
(Reporter)

Comment 2

8 years ago
Created attachment 392730 [details]
Correct display using 3.5.2 Release

Correct display using 3.5.2 Release
(Reporter)

Comment 3

8 years ago
Errors thrown in 3.6a1pre's JS console which aren't seen in Firefox 3.5.2/3.5.3pre

Error: setting a property that has only a getter
Source File: http://b2.bst.126.net/0803000/js/gen/core1.js
Line: 5026

Error: Const is not defined
Source File: http://b2.bst.126.net/0803000/js/gen/core2.js
Line: 77

Error: gNameSpace is undefined
Source File: http://b1.bst.126.net/0803000/js/gen/core3.js
Line: 1350

Error: netease is not defined
Source File: http://b.bst.126.net/js/home/photoModule.js
Line: 22

Error: NetEase.PageLayer is not a constructor
Source File: http://b2.bst.126.net/0804000/js/gen/home.js
Line: 58

Error: Const is not defined
Source File: http://b.bst.126.net/js/utils/InfoAlertPad.js
Line: 1
Confirmed on Windows Vista that there is a piece of the page not loading.
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk

Comment 5

8 years ago
Looks like bug 480206 --> tech evangelism

(I don't know exactly what language to file this under...)
Assignee: nobody → chinese-simplified
Blocks: 347174
Status: UNCONFIRMED → NEW
Component: DOM → Chinese-Simplified
Ever confirmed: true
OS: Windows XP → All
Product: Core → Tech Evangelism
QA Contact: general → chinese-simplified
Hardware: x86 → All
Version: Trunk → unspecified

Comment 6

8 years ago
3.5.3pre can show the page of http://blog.163.com/,
But 3.6.a1 can't show!
Why?
Duplicate of this bug: 525144

Comment 8

8 years ago
Any progress of this bug? Almost 3 months and the latest nightly build is still not able to load the page correctly.

Comment 9

8 years ago
Has anyone contacted the site and attempted to get them to fix this?

Comment 10

8 years ago
How could this site be called broken as it is OK in IE, Chrome, and even latest release version of Firefox? Just because it doesn't work in the latest pre-release version of Firefox?

Comment 11

8 years ago
Comment 3 makes it pretty clear the site is doing something wrong.

Comment 12

8 years ago
Did you ever notice the first line of comment 3?

"Errors thrown in 3.6a1pre's JS console which aren't seen in Firefox
3.5.2/3.5.3pre"

Or you are telling us Firefox 3.6 is the version that designed to break something that is supported before?
Firefox 3.6 added a feature. This site uses code that is not compatible with this new feature. Most other browsers have this exact same feature. The feature is defined by HTML5). The reason this works in other browsers that has the same feature, but not firefox is because it contains code like:

if (is_firefox) {
  ... bad code that is incompatible with feature ...
}

There is nothing we can do on our end to fix this site.
(Reporter)

Comment 14

8 years ago
It seems the devs of 163 have begun to use Firefox.

Resolved.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.