[HTML5][Patch] <!-- inside an xmp element is occasionally a problem

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: john.s.thomsen, Assigned: hsivonen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090806 Minefield/3.6a1pre

 

Reproducible: Always

Steps to Reproduce:
1. Set html5.enable true in about:config
2. Load this document:

data:text/html,<xmp><!--</xmp>

Actual Results:  
The page shows the text:

<!--</xmp>


Expected Results:  
The page should only show the text:

<!--


In contrast to the about doc, the following document:

data:text/html,<xmp><!--xmp--></xmp>

behaves as expected, because it shows and only shows the content of the xmp element:

<!--xmp-->
s/the about doc/the above doc/
Is this a problem with a published Web page out there?

For reference, WebKit and IE reparse with <xmp>:
http://software.hixie.ch/utilities/js/live-dom-viewer/saved/201
http://software.hixie.ch/utilities/js/live-dom-viewer/saved/202
Status: UNCONFIRMED → NEW
Ever confirmed: true
I wrote up a relatively radical proposal for a fix:
http://wiki.whatwg.org/wiki/CDATA_Escapes
Priority: -- → P1
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Summary: [HTML5] <!-- inside an xmp element is occasionally a problem → [HTML5][Patch] <!-- inside an xmp element is occasionally a problem
http://hg.mozilla.org/mozilla-central/rev/d01a520e3fd1
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.