Make use of zoom controls for calendar views

RESOLVED FIXED in 1.0b1

Status

Calendar
Calendar Views
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

unspecified
1.0b1

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 393458 [details] [diff] [review]
Fix - v1

There are zoom controls in the Thunderbird view menu, I'd like to make use of them. There are two existing similar bugs, but I decided to open a new bug since both have patches. and solve things a little differently.

This patch is dead simple, it just increments/decrements the hours in view/weeks in view options for day,week and multiweek views. I admit this is not a true "zoom" functionality, but it at least improves the situation. 

Sunbird should probably change the "weeks in view" menu to a zoom menu similar to Thunderbird, but since we are in string freeze and this is rather an enhancement, I left things as they are. I will likely file a followup bug to have that menu changed and to localize the zoom keys.

gekachecka, could you decide if this bug sufficiently superceeds bug 359624 and/or bug 366989 and mark those bugs accordingly?
Attachment #393458 - Flags: review?(Mozilla)
Attachment #393458 - Flags: review?(Mozilla) → review+
Comment on attachment 393458 [details] [diff] [review]
Fix - v1

Simple but good.

Only thing that comes to my mind is that the resetZoom function always resets to a constant value, which is not user-configurable. So if I zoom i can't return to directly to a value I had set before.

But since I can do that quite easily by zooming with the hotkeys, this shoudn't be much of a problem.

Else I only found two style nits:

Remove spaces after </method>:
+      <method name="zoomReset">
+        <body><![CDATA[
+          cal.setPref("calendar.view.visiblehours", 9);
+        ]]></body>
+      </method>
+      
     </implementation>

and remove spaces after </property>:
+++ b/calendar/base/content/calendar-views.xml
@@ -141,6 +141,33 @@
                     return val;
                 ]]></setter>
             </property>
+            
+            <property name="supportsZoom" readonly="true"
+                      onget="return true;"/>

with that r=Markus
(Assignee)

Comment 2

9 years ago
I chose that default value since its also the default value we have when shipping sunbird/lightning. I'm sure this can be improved somehow, but I agree it can be easily worked around

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/d2b6fbb6b96a>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 3

9 years ago
Interface uuid changed in changeset 2ea9a2b28886
(Assignee)

Updated

9 years ago
Blocks: 509949
(Assignee)

Updated

8 years ago
Duplicate of this bug: 522067
(Assignee)

Comment 5

6 years ago
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.