XSLT Page Zoom breaks display area. Inconsistent CSS

RESOLVED DUPLICATE of bug 560145

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 560145
9 years ago
8 years ago

People

(Reporter: cprevoe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13

XSLT transformation with a page zoom incorrectly determines the visual page area, either hiding scrollbars or not using the entire display area.

Reproducible: Always

Steps to Reproduce:
1.Take any xslt transformation converting XML to HTML (best seen when result has a div with a border)
2.Hold CTRL and use mouse wheel to do page zoom
3.after zooming, hit CTRL+R to refresh the page
4. Resizing (even a pixel) fixes things
Actual Results:  
If zooming in, scrollbars are off the screen.
If zooming out, scrollbars box out a portion of display area and the rest tends to be a garbage image.

Expected Results:  
I would expect the scrollable area to be the size of the display area, and refreshing the page to result in the same thing (when DOM not modified) as when zoomed.

<!-- XML -->
<?xml-stylesheet type="text/xsl" href="arg.xsl" ?>
<example><of>The resizing bug</of></example>

<!-- XSL  -->
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
  <xsl:template match="/">
    <html>
      <head><style> body, div { border: 1px solid black; } </style></head>
      <body><xsl:for-each select="example/of"><div><xsl:value-of select="text()" /></div></xsl:for-each></body>
    </html>
  </xsl:template>
</xsl:stylesheet>

Comment 1

8 years ago
This has also been confirmed on Ubuntu 9.10 using Firefox 3.5.7 and Firefox 3.7a1. The bug report can be found here: https://bugs.launchpad.net/firefox/+bug/515725 and is now linked to this bug.

Updated

8 years ago
I stumbled upon this bug while going through Core bugs (in particular, those with "CSS") that are languishing in Firefox::General.


Marking as duplicate of a later bug that has a testcase...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Resolution: --- → DUPLICATE
Duplicate of bug: 560145
You need to log in before you can comment on or make changes to this bug.