Closed Bug 509443 Opened 13 years ago Closed 13 years ago

bad rendering when scrolling panels in Firebug

Categories

(Core :: Layout, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: rcampbell, Assigned: roc)

References

Details

(Whiteboard: [firebug-p1])

seeing some pretty extreme tearing and rendering in Minefield/Namoroka > 20090803 (approximately).

STR:

1. Open this page
2. open Firebug (1.5), select the HTML panel
3. try rapidly scrolling the HTML page (expanding nodes if necessary) or the Styles subpanel in Firebug

http://getfirebug.com/releases/firebug/1.5X/
OS: Mac OS X → All
Whiteboard: [firebug-p2]
Blocks: 491553
Related bug (I think?) from the Firebug issue tracker -- "console tab - error on scrolling":
http://code.google.com/p/fbug/issues/detail?id=2178

Also via that bug, I did some triaging on this. In short:

Minefield 2009-08-01 -- Scrolling ok in Firebug
Minefield 2009-08-02 -- Scrolling broken in Firebug

(Just for completeness, I'm running this build at the moment: Mozilla/5.0 (Macintosh;
U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090801 Minefield/3.6a1pre)

Also, in case it might help narrow things down, here's the thread from MozillaZine
about the 20090802 Trunk build that goes over the commits that had just landed:
http://forums.mozillazine.org/viewtopic.php?f=23&t=1394135
Boris, can you point this bug in the right direction? The issue is confirmed by three experienced users and has some regression analysis. Note that the Firebug panels are 'browser' elements with HTML, so this is a bug FF3.6 will want to fix.
(In reply to comment #1)
> Minefield 2009-08-01 -- Scrolling ok in Firebug
> Minefield 2009-08-02 -- Scrolling broken in Firebug

In the future, when posting data like this... it's helpful to say what platform's nightlies you used (since they can be done at slightly different times), though I think you're saying you used Mac OS X... and even better if you include the SourceStamp= line from the application.ini file in that nightly, since then we know exactly what code it was built from.

In any case, a slightly-overly-broad regression range for that change is probably http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-08-01+00%3A00%3A00&enddate=2009-08-02+08%3A00%3A00
which makes me think that the regression was almost certainly caused by http://hg.mozilla.org/mozilla-central/rev/79db77b024f7
Blocks: 506615
The other question is whether http://hg.mozilla.org/mozilla-central/rev/e6034ded61fd fixed it.  Today's Linux x86_64 nightly crashes on startup, so it'll take me a bit to figure that out.
(In reply to comment #3)
> (In reply to comment #1)
> > Minefield 2009-08-01 -- Scrolling ok in Firebug
> > Minefield 2009-08-02 -- Scrolling broken in Firebug
> 
> In the future, when posting data like this... it's helpful to say what
> platform's nightlies you used (since they can be done at slightly different
> times), though I think you're saying you used Mac OS X... and even better if
> you include the SourceStamp= line from the application.ini file in that
> nightly, since then we know exactly what code it was built from.

Is the versions string from  
  Firefox > Help > About 
adequate?
(In reply to comment #3)
> which makes me think that the regression was almost certainly caused by
> http://hg.mozilla.org/mozilla-central/rev/79db77b024f7

I verified by local backout that this is the case.


(In reply to comment #5)
> Is the versions string from  
>   Firefox > Help > About 
> adequate?

For approximation of regression ranges, yes.

For the most minimal regression range based on the data given, no.

To get those based only on the build date, that I'd have to download and unpack the nightlies that you were using (which for non-Linux nightlies requires that I use the same platform) and then look at the application.ini in those archives.
(In reply to comment #4)
> The other question is whether
> http://hg.mozilla.org/mozilla-central/rev/e6034ded61fd fixed it.  Today's Linux
> x86_64 nightly crashes on startup, so it'll take me a bit to figure that out.

Based on today's Linux 32-bit nightlies, this appears to in fact be the case.  So fixed in today's builds.
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: 507334
Hardware: x86 → All
Resolution: --- → FIXED
Still seeing this issue with 2009-08-15-032547 on OSX and 2009-08-15-045529 on Win32. (I don't have a Linux machine on which to test, so I can't say one way or the other on that OS.)

For whatever reason, scrolling up seems to work most (or all?) of the time, but scrolling down always produces tearing for me. Also -- not sure if this is related -- but while I can move the scroll-thumb by turning my mousewheel (as usual), I'm unable to click and drag the scroll-thumb within Firebug's panes.

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Are those 1.9.2 builds or mozilla-central (1.9.3) builds?
Flags: blocking1.9.2?
Also, could you describe what you mean by "tearing"?  The behavior I saw on Linux was that the scrolling repainted the area at the very edge of the scrollable area (i.e., the part that was supposed to be repainted on each step of the scrolling) but didn't repaint any of the area in the middle that should have been blitted.

Also, do you have smooth scrolling on or off, and does the behavior change if you change it?
(In reply to comment #9)
> Are those 1.9.2 builds or mozilla-central (1.9.3) builds?

Those are 1.9.3 (Minefield/3.7a1pre) builds on each machine, though I did additionally try the today's 1.9.2 build (2009-08-15) on the Win32 machine and I saw the bug there as well. 

(I didn't happen to try today's 1.9.2 build on the OS X machine, but I could do so if you thought it'd make a difference.)

(In reply to comment #10)
> Also, could you describe what you mean by "tearing"?  The behavior I saw on
> Linux was that the scrolling repainted the area at the very edge of the
> scrollable area (i.e., the part that was supposed to be repainted on each step
> of the scrolling) but didn't repaint any of the area in the middle that should
> have been blitted.

Yes, the behavior that I'm seeing is precisely as you describe (namely, that the very edge of the scrolling area was repainted but the center-ish area was not repainted). 

(As I'm not a low-level graphics person, I apologize if my wording on that was sub-optimal.)

> Also, do you have smooth scrolling on or off, and does the behavior change if
> you change it?

I happen to have smooth scrolling on, but I saw no behavior change after turning it off.
i can confirm that

* scrolling using the buttons on the scroll bar does not work in the panels
* scrolling using mouse wheel works
* while scrolling upwards with the mouse wheel, there are repainting issues
* repainting issues are independent of smooth scrolling setting

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090816 Minefield/3.7a1pre ID:20090816045208
(http://hg.mozilla.org/mozilla-central/rev/ef2e4699b319)

firebug-1.5X.0a21
Status: REOPENED → NEW
still confirming this bug's presence on 1.9.2/Namoroka in OS X.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 ID:20090729211433

As XtC4 mentions in C#12, the scroll bar's thumb does not work, but scrolling with the wheel works or scrollbar arrows does. Repainting issues abound.
Time to get Firebug working on FF 3.6
Whiteboard: [firebug-p2] → [firebug-p1]
Assignee: nobody → roc
For what it's worth, the build id from about: is a good start for regression hunting; much more useful than just the build date.  Even better is the changeset ID from about:buildconfig.
(In reply to comment #16)

Yup, scrolling works fine with that build
Firebug 1.5x.0a21 / OS X 10.5.8
Depends on: 511951
No longer depends on: 507334
Whiteboard: [firebug-p1] → [firebug-p1][depends on 511951]
just to report about the current state of this bug, we're seeing fixed scrolling on trunk (moz-central) nightlies now, but not on Namoroka. Are we still waiting for a patch to be backported?
Yes. Let me just approve dbaron's blocking request so I can land on branch...
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P1
Fixed by checkin for bug 511951.
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Fixed on branch by checkin for bug 511951.
Whiteboard: [firebug-p1][depends on 511951] → [firebug-p1]
(In reply to comment #21)
> Fixed on branch by checkin for bug 511951.

Verified fixed using a Namoroka nightly build [1] with Firebug
1.5X.0a24.

[1] Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre)
Gecko/20090923 Namoroka/3.6b1pre (.NET CLR 3.5.30729)
verified on yesterday's Namoroka nightly with Firebug 1.5a24. Thanks for verifying as well, Helder!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.