Keyword searches in the autocomplete popup no longer update synchronously

RESOLVED WONTFIX

Status

()

Toolkit
Places
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: mstange, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Steps to reproduce:
 1. Create a bookmark with the keyword "b" and the url
    https://bugzilla.mozilla.org/show_bug.cgi?id=%s
 2. Copy the number 455555 to your clipboard.
 3. Press Cmd+Tab, type "b ", paste 455555.

Expected results:
The first entry in the autocomplete suggestions should immediately be updated to https://bugzilla.mozilla.org/show_bug.cgi?id=455555

Actual results:
There's a small delay before the update happens.

This means that if you've got the "Enter Selects" extension installed and press enter directly after you've pasted the bug number, you'll end up on https://bugzilla.mozilla.org/show_bug.cgi?id=b
I'm not sure we actually can/want to do anything about this.  With the synchronous autocomplete, we used to perform the keyword query before we would exit startSearch, so it would update right away.  Now there is always going to be a slight delay because it is asynchronous.  It should be noted that keyword searches work just fine without enter selects.

Comment 2

9 years ago
(In reply to comment #1)
> synchronous autocomplete, we used to perform the keyword query before we would
> exit startSearch, so it would update right away.
Not quite.. Keyword searches happened on the timer just like the adaptive and history results. The reason why it worked before is that keyword results would notify the front-end that results are available immediately.

Whereas now with async, the front-end is only notified after mozstorage exceeds the 75ms async batching timeout. So the keyword search might finish early and mozstorage continues with adaptive and history search.

So if your keyword search matches 15 results, it will immediately update the UI, but if it matches less than that, there will be the 75ms delay.

> It should be noted that keyword searches work just fine without enter selects.
It works if you don't try selecting the stale result from the list and just let the browser use the non-autocomplete-resolution of keyword searches.

If you typed <keyword> <search> <down> <enter>, it would still pick the stale result because of async.
I think the add-on should handle async behavior, we are not going back to synchronous behavior at this point.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.