Context Menu "View Background Image" Disabled

VERIFIED DUPLICATE of bug 482941

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 482941
8 years ago
8 years ago

People

(Reporter: megsuma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre

Using Minefield, I was testing a site I'm working on and noticed that the context menu entry for "View Background Image" is disabled, even though I have a CSS background-image attached to the body:

body {
	background-image:url('../images/logo.png');
	background-repeat: no-repeat;
	background-color: #fff;
}

which is <link>'d to the head of the HTML document. I seem to remember this working in versions < Minefield.

Reproducible: Didn't try

Steps to Reproduce:
1. Create an HTML file and CSS file (foo.html, bar.css) and get a png image (logo.png in my case).
2. Link CSS file to HTML file: <link rel="stylesheet" type="text/css" href="bar.css" />
3. In bar.css:
body {
	background-image:url('../images/logo.png');
	background-repeat: no-repeat;
	background-color: #fff;
}
4. Right-click on page/background image

Actual Results:  
The context menu's "View Background Image" option was disabled.

Expected Results:  
"View Background Image" should be clickable and lead to the background image URL.

No crash involved - needs to be tested.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482941
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.