Hide menu does not work after restart if menu was hidden

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: FlashCode, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1) Gecko/20090806 Namoroka/3.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1) Gecko/20090806 Namoroka/3.6a1

I hide menu with new option (uncheck of View => Toolbars => Menu bar).
Then I close Firefox and open it again.
Menu is displayed, but option Toolbars => Menu bar is still unchecked.
If I check or uncheck it, option does not work, menu is always displayed.

Reproducible: Always

Steps to Reproduce:
1.start firefox, hide menu (uncheck of View => Toolbars => Menu bar)
2.close firefox
3.start firefox
Actual Results:  
Menu is displayed, but option "Menu bar" is unchecked. It's not possible to hide menu again.

Expected Results:  
Hidden menu bar.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre

This works normally here. Menu is not displayed after a restart. After putting a check mark in the box the menubar is visible again.

Can you try the following troubleshooting options:

- Firefox's safe-mode to exclude extension/theme problems
- a new profile
- a reinstall in a new empty folder 

http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
You're right, with a new profile, I don't have problem.

Now I'm asking me what is the problem, because I uninstalled all add-ons, and I still have problem with my main profile. So I think problem is in profile and not in add-ons/plugins...
Could be a profile corruption. One of the files (or more files in your profile might be corrupt). The file where toolbar configuration info is stored, is called localstore.rdf. Removing this file resets the toolbars to default.
(Reporter)

Comment 4

8 years ago
After removing localstore.rdf, bug has gone.
I think this bug can be closed, thanks for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 5

8 years ago
I would kindly ask to reopen this bug, as I have the same thing and I have step by step how to reproduce it:

1. Hide the menu bar by clicking View>Toolbars>Menu Bar
2. press left Alt on keyboard to show menus
3. restart Firefox

there you go, there is no way to hide menu bar now

I hope that someone will reopen this bug, otherwise, I'll have to submit new one.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b6pre) Gecko/20091227 Namoroka/3.6b6pre

I think it would be best to file a new bug Ivan, although I can't reproduce your STR. After Alt left, closing and reopening Firefox, the menubar is collapsed.

Comment 7

8 years ago
(In reply to comment #6)
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b6pre) Gecko/20091227
> Namoroka/3.6b6pre
> 
> I think it would be best to file a new bug Ivan, although I can't reproduce
> your STR. After Alt left, closing and reopening Firefox, the menubar is
> collapsed.

Oops, thanks for the info, actually I was wrong, on clean profile it still can't be reproduced. But on my working profile, whenever I exit Firefox with hidden menu, I can't hide it in that session, and whenever I exit Firefox with Menus shown, I can hide it in next session... Actually no alt press is required.

And I just got used on using this profile for last several years... It looks that I'll have to remember that pre-1.0 days when you had to clean your profile regularly to get new version working :(.

Though I affraid that this might happen to other (normal) users that have no idea what clean profile is, and possibly I should file the bug, what do you think?

Comment 8

8 years ago
> hidden menu, I can't hide it in that session
should be next session, not that session...
You can always file a bug, especially if the bug can also be reproduced in safe-mode so it is clear that it isn't caused by an add-on.
CC-ing hskupin@gmail.com, who is often interested in this kind of cases.

Comment 10

8 years ago
Well, Safe mode doesn't record that menu bar is hidden, so there is no way to reproduce it there. As advised above, I filed a new bug, bug 537169.
(In reply to comment #4)
> After removing localstore.rdf, bug has gone.
> I think this bug can be closed, thanks for your help.

Flashcode, I suspect that you have no access anymore to your former localstore.rdf? Deleting files is always a bad idea when we have to check for bugs. Please just move the file away the next time. Marking bug as WFM which is the correct resolution here.
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.