Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 5099 - need to add LANG to nsFont
: need to add LANG to nsFont
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All Other
: P3 normal (vote)
: M9
Assigned To: Peter Linss
: Christine Hoffman
: Jet Villegas (:jet)
Depends on:
Blocks: 7228 7521
  Show dependency treegraph
Reported: 1999-04-14 15:12 PDT by Erik van der Poel
Modified: 2005-03-17 13:34 PST (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Erik van der Poel 1999-04-14 15:12:04 PDT
Unicode unifies the CJK (Chinese, Japanese, Korean) range. HTML has introduced
the LANG attribute. The spec says that this is to be used for CJK
disambiguation, among other things. So if the CSS resolves to a generic font
like "serif", then we need to select the right font (C, J or K) depending on
the language.

The LANG attribute can be specified for individual elements, and is inherited
from parent elements. If the HTML document does not have any LANG attributes,
the HTTP headers should be examined for the Content-Language header. If that is
missing too, the LANG should be NULL in nsFont. In that case, we can use the
charset of the document as a fallback (heuristic). A separate bug report will
be filed for the charset.

Since LANG is an ASCII string, the nsFont field can be either char* or nsString.
If it is simpler to use nsString, please do so.
Comment 1 bobj 1999-04-14 15:59:59 PDT
Erik is dependent upon this before M7.
Comment 2 Peter Linss 1999-08-05 11:04:59 PDT
Adding lang to nsFont is not the right location, the style system re-uses
nsFont for different content nodes which may be in dofferent languages.
Comment 3 Christine Hoffman 1999-08-05 16:19:59 PDT
Verified WONTFIX
Comment 4 bobj 1999-08-06 18:18:59 PDT
See peterl's 08/06/99 16:01 comment in bug 6451.

Note You need to log in before you can comment on or make changes to this bug.