Closed Bug 509970 Opened 10 years ago Closed 9 years ago

xpcshell-tests: random failure in test_removeVisitsByTimeframe.js | 2 == 10, 6 == 10, etc.

Categories

(Firefox :: Bookmarks & History, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b9
Tracking Status
status1.9.2 --- ?
status1.9.1 --- ?

People

(Reporter: jrmuizel, Unassigned)

References

Details

(Keywords: intermittent-failure)

Blocks: 438871
Whiteboard: [orange]
i've just seen this on my local box, this means it's probably reproduceable and not only tinderboxes driven.

This is the failure point:

      print("Run a history query and check that all visits still exist.");
      var query = histsvc.getNewQuery();
      var opts = histsvc.getNewQueryOptions();
      opts.resultType = opts.RESULTS_AS_VISIT;
      opts.sortingMode = opts.SORT_BY_DATE_DESCENDING;
      var resultRoot = histsvc.executeQuery(query, opts).root;
      resultRoot.containerOpen = true;
==>   do_check_eq(resultRoot.childCount, 10); 

the query is returning only 1 child.
Depends on: 507790
this is due to bug 507790, using UNION ALL in the query means the sync can run in the middle of the query changing underlying data.
Summary: TEST-UNEXPECTED-FAIL | /builds/moz2_slave/mozilla-central-linux-unittest-everythingelse/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js → random failure in test_removeVisitsByTimeframe.js
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1251796884.1251804890.12161.gz
WINNT 5.2 comm-1.9.1 unit test on 2009/09/01 02:21:24

TEST-UNEXPECTED-FAIL | ... | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ... | 2 == 10 - See following stack:
Summary: random failure in test_removeVisitsByTimeframe.js → xpcshell-tests: random failure in test_removeVisitsByTimeframe.js
OS: Mac OS X → All
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251886735.1251888474.6000.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/09/02 03:18:55
Depends on: 521225
Whiteboard: [orange] → [orange][workarounded by bug521225 on trunk]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1267482982.1267483981.25491.gz
WINNT 5.2 mozilla-1.9.2 test xpcshell on 2010/03/01 14:36:22
s: win32-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1267540770.1267541435.25281.gz
Linux mozilla-1.9.2 test xpcshell on 2010/03/02 06:39:30
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1268688139.1268689110.32240.gz
WINNT 5.2 mozilla-1.9.2 opt test xpcshell on 2010/03/15 14:22:19
s: win32-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1269256604.1269257348.27838.gz#err0
Linux mozilla-1.9.2 opt test xpcshell on 2010/03/22 04:16:44
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1269901313.1269902066.14577.gz
WINNT 5.2 mozilla-1.9.2 opt test xpcshell on 2010/03/29 15:21:53
s: win32-slave29
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270057700.1270059854.32102.gz
Linux mozilla-central debug test xpcshell on 2010/03/31 10:48:20
s: moz2-linux-slave05
Comment 21's failure is different:

TEST-UNEXPECTED-FAIL | /builds/moz2_slave/mozilla-central-linux-debug-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | test failed (with xpcshell return code: 0), see following log:

TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsINavBookmarksService.removeFolderChildren]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: /builds/moz2_slave/mozilla-central-linux-debug-unittest-xpcshell/build/xpcshell/tests/test_places/unit/head_bookmarks.js :: remove_all_bookmarks :: line 199"  data: no]

Which is the same error as over in bug 555014.
Nice work on my part :( - altered the summary to maybe catch myself the next time.
Summary: xpcshell-tests: random failure in test_removeVisitsByTimeframe.js → xpcshell-tests: random failure in test_removeVisitsByTimeframe.js | 2 == 10, 6 == 10, etc.
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1277440228.1277440647.23749.gz
Linux mozilla-1.9.2 opt test xpcshell on 2010/06/24 21:30:28

s: mv-moz2-linux-ix-slave12
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | 2 == 10 - See following stack:
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1277518249.1277518620.15210.gz
Linux mozilla-1.9.2 test xpcshell on 2010/06/25 19:10:49

s: mv-moz2-linux-ix-slave23
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | 2 == 5 - See following stack:
Not positive this is the same but it looks like branches are being starred against this bug with different results than the summary so I'm doing so as well.

Linux mozilla-1.9.2 test xpcshell on 2010/09/24 12:02:13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1285354933.1285355276.11926.gz

TEST-PASS | /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | [anonymous : 172] true == true
Run a history query and check that only the older 5 visits still exist.
<a name='err1'></a><font color='000080'>TEST-UNEXPECTED-FAIL | /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | 4 == 5 - See following stack:
</font>JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 200
JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 230
JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: anonymous :: line 182
JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: anonymous :: line 425
JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: run_test :: line 422
JS frame :: /builds/moz2_slave/mozilla-1.9.2-linux-unittest-xpcshell/build/xpcshell/head.js :: _execute_test :: line 128
JS frame :: -e :: &lt;TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test
Looks like I hit this on Firefox 3.6.11 build 2

TEST-PASS | /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | [anonymous : 172] true == true
Run a history query and check that only the older 5 visits still exist.
TEST-UNEXPECTED-FAIL | /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js | 1 == 5 - See following stack:
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 200
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 230
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: anonymous :: line 182
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: anonymous :: line 425
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_places/unit/test_removeVisitsByTimeframe.js :: run_test :: line 422
JS frame :: /builds/slave/release-mozilla-1.9.2-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: _execute_test :: line 128
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test
This should now have been fixed by the Places branch merge.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange][workarounded by bug521225 on trunk] → [orange]
Target Milestone: --- → Firefox 4.0b9
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.