When restoring windows/tabs on start, FireFox shows cached out-of-date pages

RESOLVED DUPLICATE of bug 706970

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 706970
9 years ago
5 months ago

People

(Reporter: Ihar 'Philips' Filipau, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

When "Show my windows and tabs from last time" is active, FireFox after start shows cached, out-of-date version of web pages.

This is extremely counter-intuitive: one starts browser anew, but information shown is outdated. Worst part is that the fact is not immediately obvious.


Reproducible: Always

Steps to Reproduce:
1. Open some dynamic pages in FireFox
2. Activate "Show my windows and tabs from last time" under "Tools - Option - Main - Startup - When FireFox starts".
3. Close FireFox
4. Update the information on the pages by other means (or wait for news site to get new headlines)
5. Open FireFox
Actual Results:  
FireFox displays outdated information

Expected Results:  
FireFox should load and display fresh information in tabs/windows.

P.S. This is one of my most hated Opera /features/ which can't be turned off. Sadly FireFox is affected now too.

P.P.S. I see that many 3.5 features do not have any configuration parameters in about:config. Is that new party line?

Comment 1

9 years ago
This is intentional: For faster startup we display the "windows and tabs from last time" (and not tabs that look slightly like the ones from last time) whenever possible. Nonetheless, we should respect a web page's indication whether it might need refreshing after the restoration.
Whiteboard: DUPEME?
(Reporter)

Comment 2

9 years ago
There is no need to break all the work which went into the faster start-up.

It would be more than sufficient to have an option in about:config.

Updated

7 years ago
Whiteboard: DUPEME? → DUPEME
Version: unspecified → 3.5 Branch

Updated

6 years ago
Duplicate of this bug: 718523

Comment 4

4 years ago
Tim, do you know what this might be a dupe of?
Flags: needinfo?(ttaubert)
I do!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ttaubert)
Resolution: --- → DUPLICATE
Duplicate of bug: 706970
You need to log in before you can comment on or make changes to this bug.