Code coverage for Electrolysis

RESOLVED DUPLICATE of bug 1314305

Status

Testing
Code Coverage
RESOLVED DUPLICATE of bug 1314305
9 years ago
a year ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: murali)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The Electrolysis project is moving forward and we'll need to figure out some way to capture code coverage results from multiple processes. In the beginning this may only mean one chrome process and one content process but eventually we may start launching a new subprocess for every origin.

Do our current code coverage tools have any way to handle the output of multiple processes?
(Assignee)

Updated

9 years ago
Assignee: nobody → mnandigama
(Assignee)

Comment 1

9 years ago
Ben,

I would be able to answer your questions as soon as we have a brief discussion about your requirements. I am working from home today. Can we meet tomorrow ?

Murali
(Assignee)

Comment 2

9 years ago
I am in need to know the list of tests that can be run on an instrumented build that test Electrolysis features.
(Assignee)

Comment 3

9 years ago
Please provide the fully qualified hg branch URL that I should use to clone the source code.

Comment 4

9 years ago
We don't have automated tests yet... the test harness we're using is dom/ipc/test.xul (see https://wiki.mozilla.org/Content_Processes/Build). I think this bug is more about making sure that the test apparatus is ready to hook up to multiple processes and deal with the results.
(In reply to comment #4)
> making sure that the test apparatus is ready to
> hook up to multiple processes and deal with the results.

Indeed. Just wanted to get this on your radar.
Blocks: 1278393
Depends on: 1314305
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314305
No longer blocks: 1278393
No longer depends on: 1314305
You need to log in before you can comment on or make changes to this bug.