Closed Bug 510323 Opened 11 years ago Closed 11 years ago

Multiline <select> doesn't ignore middle clicks correctly

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Steps to reproduce problem:
1. Find a scrolling multiline select (e.g. a bug with many CCs)
2. Middle-click it (if you have autoscroll enabled, use ESC to cancel it)
3. Move the mouse around in the area of the select

Expected result: nothing happens

Actual results: drag-selection effect

This is caused by nsListControlFrame being too eager to set mButtonDown.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #394364 - Flags: review?(Olli.Pettay)
Attachment #394364 - Flags: review?(Olli.Pettay) → review+
Pushed changeset fd73d914b2b1 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: wanted1.9.2?
Target Milestone: --- → mozilla1.9.3
Target Milestone: mozilla1.9.3 → mozilla1.9.3a1
Comment on attachment 394364 [details] [diff] [review]
Proposed patch

This patch is needed for  Bug 295977 to function correctly in the case when autoscrolling a multiple select box.

The patch has been baking for more than a week, no performance impact or risk.
Attachment #394364 - Flags: approval1.9.2?
Attachment #394364 - Flags: approval1.9.2? → approval1.9.2+
Flags: wanted1.9.2?
Flags: wanted1.9.2-
Flags: blocking1.9.2-
Pushed changeset 523ca9b9773d to releases/mozilla-1.9.2
You need to log in before you can comment on or make changes to this bug.