Closed Bug 510593 Opened 10 years ago Closed 9 years ago

BenchJS: 70% slower than Opera

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: wbrana, Unassigned)

Details

Attachments

(1 file)

54.86 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a2pre) Gecko/20090814 Minefield/3.6a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a2pre) Gecko/20090814 Minefield/3.6a2pre

Firefox 3.6a2pre is 70% slower in average than Opera 10 beta3 in BenchJS benchmark. See attachment for BenchJS.

Reproducible: Always

Actual Results:  
opera-10.00-4546.gcc4-qt4.x86_64.tar.bz2
TEST 1 time: 0.504 sec.
TEST 2 time: 0.783 sec.
TEST 3 time: 0.122 sec.
TEST 4 time: 0.072 sec.
TEST 5 time: 0.024 sec.
TEST 6 time: 0.685 sec.
TEST 7 time: 0.076 sec.

firefox-3.6a2pre.en-US.linux-x86_64.tar.bz2
TEST 1 time: 1.074 sec.
TEST 2 time: 0.393 sec.
TEST 3 time: 0.273 sec.
TEST 4 time: 0.134 sec.
TEST 5 time: 0.074 sec.
TEST 6 time: 0.731 sec.
TEST 7 time: 0.086 sec.

TEST 1 213.1%
TEST 2 50.19%
TEST 3 223.77%
TEST 4 186.11%
TEST 5 308.33%
TEST 6 106.72%
TEST 7 113.16%
average 171.62%




Clean profiles. Popup blocker has to be disabled.
Attached file BenchJS benchmark
OS: Linux → All
Hardware: x86_64 → All
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
Opera/9.80 (X11; Linux x86_64; U; en-GB) Presto/2.7.62 Version/11.00
TEST 1 time: 1.121 sec.
TEST 2 time: 0.151 sec.
TEST 3 time: 0.114 sec.
TEST 4 time: 0.055 sec.
TEST 5 time: 0.01 sec.
TEST 6 time: 0.656 sec.
TEST 7 time: 0.053 sec.

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre
TEST 1 time: 1.092 sec.
TEST 2 time: 0.453 sec.
TEST 3 time: 0.268 sec.
TEST 4 time: 0.12 sec.
TEST 5 time: 0.027 sec.
TEST 6 time: 0.663 sec.
TEST 7 time: 0.021 sec.

1 - 97.41%
2 - 300%
3 - 235.09%
4 - 218.18%
5 - 270%
6 - 101.07%
7 - 39.62%
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [CLOSEME 2011-1-1]
Version: unspecified → Trunk
That's 2644ms vs 2160ms, which is only 22%.  Please file specific bugs on the patterns that are slow, if we don't already have them on file, so we can assess how to prioritize them.

You probably want to file bugs on opera about the cases where we're faster, too. :-)
OK, I looked at the benchmark more closely.

- only 3 of the tests are testing JS performance really at all (#1, #2 and #7) -- the rest are DOM or layout or a mix of things

- they time across timeouts, meaning that the performance numbers are basically worthless :-/

I'm going to generously call this FIXED instead of INVALID, because we got better at it.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
(Probably worth evangelizing the site, because wow.)
And in particular, they used timeouts with delays < 10ms, which are clamped differently in different browsers (we clamp to 10ms; Opera recently switched to clamping to 4ms, iirc).
You need to log in before you can comment on or make changes to this bug.