Preference "Return in a paragraph always creates a new paragraph" has no effect (on Mac?)

RESOLVED DUPLICATE of bug 449243

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 449243
9 years ago
6 years ago

People

(Reporter: Rainer, Unassigned)

Tracking

Trunk
x86
Mac OS X

SeaMonkey Tracking Flags

(seamonkey2.3 wontfix, seamonkey2.4 wontfix, seamonkey2.5 fixed)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090814 SeaMonkey/2.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090814 SeaMonkey/2.0b2pre

Regardless of whether the above-mentioned preference is set or not, pressing enter or return on mac only creates a new-line <br> and not a <p>. Would be nice, if simple keyboard-input could control which of both tags is inserted. I havent found a way to do that (on Mac Return vs. Command-Return would be nice)

Reproducible: Always
Version: unspecified → Trunk

Comment 1

6 years ago
Could you check this against SM2.3 and see if the issue is still present?

Comment 2

6 years ago
I think Ehsan fixed this in mozilla-central/editor recently. Does Bug 449243 ( contenteditable stuck inserting <br> instead of <p> in some cases) help?

Comment 3

6 years ago
If that is the case, then the fix will be present in SM2.5 or above. Testing against SM2.5 and trunk cannot reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
status-seamonkey2.3: --- → wontfix
status-seamonkey2.4: --- → wontfix
status-seamonkey2.5: --- → fixed
Resolution: --- → DUPLICATE
Duplicate of bug: 449243
You need to log in before you can comment on or make changes to this bug.