Unqualified schema element not handled correctly

RESOLVED INVALID

Status

Core Graveyard
XForms
RESOLVED INVALID
8 years ago
11 months ago

People

(Reporter: Josef Spillner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Firefox 3.5.2 + XForms 0.8.7pre (Gecko v1.9.1.1pre - 2009071509)

I've got two semantically equivalent XHTML+XForms pages showing the output of a fortune webservice.
On the syntax level, one is the original which contains an unqualified element as part of the XML Schema. XForms doesn't display this element, but also no error console comes up. The second one has been prepared manually to let the element be qualified. It shows up correctly.

Both pages show "Failed to process inline schema" in the error console. This seems to be a separate issue because one of the pages works just fine.


Reproducible: Always

Actual Results:  
One element is not shown in the XForms output.

Expected Results:  
The fortune slogan should be shown.
(Reporter)

Comment 1

8 years ago
Created attachment 394640 [details]
The original, non-working page
(Reporter)

Comment 2

8 years ago
Created attachment 394641 [details]
The fixed, working page

Comment 3

8 years ago
That's expected behaviour for the unqualified version, since your default namespace is the XHTML one, and thus the "return" element in the instance will  be in that namespace.
(Reporter)

Comment 4

8 years ago
You're right, the issue here is that the wrongly generated instance section is missing an xmlns="urn:FortuneService" declaration and the discovered issue is a direct result from this.
Closing this as an invalid report myself now. The spurious validation error remains, though, it is not affected by adding the xmlns attribute.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Assignee)

Updated

11 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.