Cannot stop malicious scripts sending dialog boxes

RESOLVED DUPLICATE of bug 61098

Status

()

--
critical
RESOLVED DUPLICATE of bug 61098
9 years ago
9 years ago

People

(Reporter: o2627091, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Enter the webpage and you see. Google Chrome and Opera allow close tabs even on this webpage.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.own3d.es/
2. Try to close the tab
3. You have to close firefox from proccess manager

Comment 1

9 years ago
Link is not work safe.
(Reporter)

Comment 2

9 years ago
I am sorry, I didn´t remember to mention.
the size and moving of the window is
Tools/options/content/javascript advanced/[x]Move or resize existing windows

and JS alerts on close are bug 61098
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 61098
(Reporter)

Comment 4

9 years ago
The option Tools/options/content/javascript advanced/[x]Move or resize existing windows
 is unchecked and it does it anyway.

Look how Chrome handles it, it asks if you don´t want to allow more dialogs once you close 2 of them.
That is not how Chrome handles it, that is only the UI which is the small  smallest part of implementing something. The Chrome way in the code can not be used by us because we have a complete different rendering engine.
There is also already a patch in bug 61098, no need to install chrome on my system.
You need to log in before you can comment on or make changes to this bug.