Last Comment Bug 510764 - firefox won't start with k 2.6.29.6 (and other late kernels)
: firefox won't start with k 2.6.29.6 (and other late kernels)
Status: RESOLVED INCOMPLETE
[CLOSEME 2011-1-1]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.murga-linux.com/puppy/view...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-16 03:52 PDT by micko
Modified: 2011-01-01 07:48 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description micko 2009-08-16 03:52:10 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.22) Gecko/20090728 SeaMonkey/1.1.17
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.22) Gecko/20090728 SeaMonkey/1.1.17

Firefox 3.5.x will not run on Puppy linux using later kernels ranging from 2.6.29.6 to 2.6.30.1. These are official test versions built by Barry Kauler.

Reproducible: Always

Steps to Reproduce:
1.Load Puppy Linux (417, 422, 423 ) all official alphas and betas
2.Install firefox. (from the Puppy .pet or compile from mozilla-1.9.1 source)
3.Run. Hangs at Import Wizard. Any attempt to restart results in "Firefox is already running..." error message. See http://www.murga-linux.com/puppy/viewtopic.php?t=45566&start=45
Actual Results:  
Ranging from a restart of X to a hard reboot :(

Expected Results:  
Started

This behaviour is only exhibited in the latest kernel versions of Puppy Linux. One respected member also reported similar behaviour in Ubuntu after a kernel upgrade to 2.6.29.6
Older kernels with the exact same setup are ok AFAIK.
Thankyou.
Comment 1 Matthias Versen [:Matti] 2009-08-16 16:26:49 PDT
And why Do you think that this is a Firefox issue and not a kernel one ?

>Any attempt to restart results in "Firefox is already running..." error message.
And does killing the process work ?

>Actual Results:  
>Ranging from a restart of X to a hard reboot :(

A restart of X or a hard reboot is the actual result ?
That is either a kernel or hardware issue, Firefox is a usermode application
Comment 2 micko 2009-08-16 23:54:11 PDT
(In reply to comment #1)
> And why Do you think that this is a Firefox issue and not a kernel one ?
> 
> >Any attempt to restart results in "Firefox is already running..." error message.
> And does killing the process work ?
> 
> >Actual Results:  
> >Ranging from a restart of X to a hard reboot :(
> 
> A restart of X or a hard reboot is the actual result ?
> That is either a kernel or hardware issue, Firefox is a usermode application

>And why Do you think that this is a Firefox issue and not a kernel one ?
Because I also tried with k 2.6.30.1 and 2.6.27.7 as have others.
>And does killing the process work ?
No, Still get the same error message.
>A restart of X or a hard reboot is the actual result ?
Er, sorry about that. The result is firefox wont start at all.
>That is either a kernel or hardware issue, Firefox is a usermode application
Hmmm, perhaps it is a kernel issue, I also tried with Slackware kernel, 2.6.27.7 (compiled for Puppy) and failure, but three different kernels I tried. I also tried on 3 different machines ranging from a p3, 256 ram to a P4 1.8GHz, 1GB ram on board intel graphics, and an athlon 2100+, 768MB ram, raedon9200 graphics,   Could it be something to do with how Puppy uses a layered file system? Unionfs? Many of us at Puppy are at a loss. 
Thankyou for your help. I hope we can get to the bottom of this.
Comment 3 Tyler Downer [:Tyler] 2010-12-03 22:53:12 PST
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Comment 4 Tyler Downer [:Tyler] 2011-01-01 07:48:17 PST
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.