visibility:collapse isn't actually collapsing anymore when the selector matches a bound element.

RESOLVED DUPLICATE of bug 513318

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 513318
9 years ago
9 years ago

People

(Reporter: Natch, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows Vista
testcase
Points:
---
Bug Flags:
wanted1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
I have code that collapses richlistitems based on an attribute on the richlistbox, the problem is it's showing empty space for some of the collapsed richlistitems. This used to work just fine, and display:none still works fine as well.

I'll try to get a testcase together sometime soon...
Flags: blocking1.9.2?
(Reporter)

Updated

9 years ago
Keywords: regression, regressionwindow-wanted, testcase-wanted
Component: Style System (CSS) → XP Toolkit/Widgets: XUL
QA Contact: style-system → xptoolkit.xul
(Reporter)

Comment 1

9 years ago
This only happens when there's a binding attached to the richlistitem and new items are appended dynamically.

I can't really work up a great testcase, but I'll zip up the files involved and attach them to this bug.
Summary: visibility:collapse isn't actually collapsing anymore. → visibility:collapse isn't actually collapsing anymore when the selector matches a bound element.
(Reporter)

Comment 2

9 years ago
Created attachment 395338 [details]
testcase

STR:

1) Unzip into folder of choice and create a manifest that points to it under the name "Console".
2) Navigate to chrome://Console/content/console2.xul
3) Open a new tab and go to yahoo (to collect warnings).
4) Collect some errors (javascript:e in the location bar works).
5) Reload the console, then select the "Errors" tab.
5) Minimize window until scrollbars appear.

You'll notice that there's a bunch of empty whitespace below the last error item, although nothing actually shows. getComputedStyle doesn't report it as visibility: collapse, which is bad.

/me searches for a regression range.
(Reporter)

Comment 3

9 years ago
This has been around forever, and it's a Style bug since the style isn't being computed correctly as evidenced in the previous comment with getComputedStyle. I *think* the problem might be that the type="warning" and type="error" richlistitems are bound to the same binding, maybe confusing the system?

display: none works though, so I'll just have to use that.
Component: XP Toolkit/Widgets: XUL → Style System (CSS)
Flags: blocking1.9.2? → wanted1.9.2?
Keywords: regression, regressionwindow-wanted, testcase-wanted → testcase
QA Contact: xptoolkit.xul → style-system
(In reply to comment #2)
> 1) Unzip into folder of choice and create a manifest that points to it under
> the name "Console".

I don't know what this means.  Could you attach such a manifest?
(Reporter)

Comment 5

9 years ago
Created attachment 395410 [details]
.manifest, drop in <App Dir>/Chrome

Here's the manifest file that goes along with it. Notice, this is on a WIndows system, you'll have to change the path if you use it on another system.
(Reporter)

Updated

9 years ago
Attachment #395410 - Attachment mime type: application/octet-stream → text/plain
Your steps to reproduce work for me.  (I assume by "minimize the window" you mean "reduce the size of the window"... which I did in both dimensions, although maybe you meant only one.)
And by "work for me", I mean I don't see anything wrong.
And when I look in DOM inspector's computed style panel, the richlistitems in question show as visibility:collapse.
(Reporter)

Comment 9

9 years ago
These STR reproduce the bug 100% of the time for me,

1) open a blank page
2) continually hit enter on javascript:e (collect about 10 errors)
3) open www.yahoo.com to collect some warnings
4) Navigate to chrome://console/content/console2.xul
5) Hit the "Errors" tab, make sure the window is small enough (lengthwise) to
display scrollbars.

You'll see at the bottom some empty space at the bottom of the richlistbox that
shouldn't be there, this is on:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090818
Minefield/3.7a1pre
(Reporter)

Comment 10

9 years ago
Oh, also make sure you have the errors still in the console, it might get overwritten by the warnings from yahoo, in which case just use google.com, I think it has less warnings.
(Reporter)

Comment 11

9 years ago
Uhm, actually, just checked in DOMi and it is coming up as "collapse", not sure anymore where that space is coming from...

In any event it doesn't happen when I use display: none
By "length", do you mean width or height?
(Reporter)

Comment 13

9 years ago
Height :) sorry about that...
(Reporter)

Comment 14

9 years ago
Bug 513318 has a better testcase, duping.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513318
Flags: wanted1.9.2? → wanted1.9.2+
Was your problem fixed by the patch in bug 513318?
You need to log in before you can comment on or make changes to this bug.