Cursor can fail to change shape loading a new page (Windows)

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: smichaud, Unassigned)

Tracking

({regression})

1.9.1 Branch
All
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

This Windows-specific bug is spun off from bug 510919, and seems to be
unrelated to it, though the symptoms are similar.  It happens on the
1.9.1 branch and above.

STR:

1) Click on a link to this bug's URL
   (http://www.coteindustries.com/articles/html_articles/tabindex.html).

   Be careful not to move the mouse as you click on the link.  If you
   move it enough to change it to a pointer before the new page has
   finished loading, the bug doesn't happen.

2) A new page will load, but the mouse cursor will fail to change from
   a hand cursor back to a pointer.  It only does so when you move the
   mouse.

Regression range (on Windows)

firefox-2009-03-05-04-mozilla-central
firefox-2009-03-06-04-mozilla-central

Bug 510919 comment #1 suggests this regression may have been
caused/triggered by the patch for bug 481359.  This seems to be true
-- backing out the patch for bug 481359 stops this bug from happening.
You can see this for yourself by testing the following tryserver build
(which backs out the patch for bug 481359 in current code):

https://build.mozilla.org/tryserver-builds/smichaud@pobox.com-backout481359/backout481359-win32.zip
(Reporter)

Updated

9 years ago
Blocks: 481359
(Reporter)

Updated

9 years ago
Keywords: regression
Isn't this the same as Bug 482985 ?
(Reporter)

Comment 2

9 years ago
It sounds related.  I'm not sure it's a dup.

Markus, what do you think?
20160502172042 Mozilla/5.0 (Windows NT 5.2; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
20160515030241 Mozilla/5.0 (Windows NT 5.2; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

I could not reproduce the issue on Windows XP on the latest Firefox 46 RC and on the latest Nightly 49.0a1.
Setting the status to RESOLVED WORKSFORME.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Thanks
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.