Closed Bug 511159 Opened 11 years ago Closed 10 years ago

get unit tests running on Win32 PGO builds again

Categories

(Release Engineering :: General, defect, P2)

x86
Windows NT
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Assigned: catlee)

References

Details

(Keywords: regression)

On the 1.9.0 tree we have a Win32 PGO unittest builder. When we switched to our buildbot+hg infrastructure, we didn't bring that along, so it's a gap in our testing coverage. I think this is most easily fixed by fixing bug 486783 at this point, since if we run unit tests on the Win32 nightly builds, we're running them on PGO builds by definition. AIUI, that bug is a Q3 RelEng goal as well, so this shouldn't be adding any actual work to your plate, just tracking a regression from our 1.9.0 tree.
As per conversation with ted, it will be fixed as soon as bug 486783 is fixed without having to do anything to be done.

Nightly builds are PGO + we add unittest to nightly builds -> we fix this bug

The reason to file is to keep track that this is a regression
Not sure I follow why keeping separate bug, but Lukas is working on all the other bugs about running unittests on nightly/debug/release builds.
Assignee: nobody → lsblakk
We have a separate bug because this is a regression from coverage we had before, and many of us want that fixed regardless of what happens with the run-unit-tests-on-such-builds grander plan.

When should we expect to have the specific issue (subset of the other bug) resolved?  It affects when we can land some performance patches for Places.
Catlee is working on all the other bugs about running unittests on nightly/debug/release builds so I'm passing this one on too.
Assignee: lsblakk → catlee
These are running now, despite the dep bug still being open:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1253898484.1253900127.6607.gz
(and green, to boot)
Priority: -- → P2
(In reply to comment #5)
> These are running now, despite the dep bug still being open:
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1253898484.1253900127.6607.gz
> (and green, to boot)

can this bug be closed now?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.