Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Assignee is blank in Whine emails

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Whining
P1
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: reid, Assigned: mrbball)

Tracking

unspecified
Bugzilla 3.4
Bug Flags:
approval +
blocking3.6 +
approval3.4 +
blocking3.4.5 +

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: 3.4.1

In my whine mails, the value of the Assignee field is missing.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 395137 [details]
Sample whine e-mail demonstrating the missing value
(Reporter)

Comment 2

8 years ago
Created attachment 395140 [details] [diff] [review]
patch against 3.4.1 using assignee real name in the mails

This patch uses the assignee real name for the whine mails.

It is against 3.4.1. I realize that that's not the right way to submit a patch, but I don't yet have a HEAD install and thought that since it's so small, it would be useful anyway. A cursory glance at HEAD makes me think that it would probably apply OK.

Feedback appreciated.
Attachment #395140 - Flags: review?

Updated

8 years ago
Severity: normal → enhancement
OS: Linux → All
Priority: -- → P3
Hardware: x86 → All
Summary: Assignee value missing from whine mails → Show Assignee in Whine mails

Updated

8 years ago
Attachment #395140 - Flags: review? → review?(wicked)
(Assignee)

Comment 3

8 years ago
Created attachment 407776 [details] [diff] [review]
V2 - patch against tip, keeping assignee login name in the whine email

I just had this problem reported on my 3.4.1 installation.  

I see that the issue is that "map_assigned_to.login_name" now gets
mapped back to "assigned_to" by Search.pm::COLUMNS(), when the
select column list is built at line 927 (in Search.pm::init()).
Thus, that is the name that is used to build the "bug" arrays in
whine.pl::run_queries(), and ultimately the name that must be used
in the whine/mail.* templates.

This patch is against the tip and leaves login_name in the whine emails.

BTW, this is a bug, not an enhancement.  Assignee was there in 3.2.4
whine emails but is missing in 3.4.1 whine emails.
Attachment #407776 - Flags: review?(wicked)

Updated

8 years ago
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking3.4.5+
Priority: P3 → P1
Target Milestone: --- → Bugzilla 3.4

Comment 4

8 years ago
By the way, the reason that this bug was not given the appropriate priority before was that the summary described a solution, not a problem. Usually enhancements describe a solution, and bugs describe a problem.
Summary: Show Assignee in Whine mails → Assignee is blank in Whine emails

Updated

8 years ago
Assignee: whining → kar
(Reporter)

Comment 5

8 years ago
Max, my original summary was "Assignee value missing from whine mails" which seems quite similar to me to the current "Assignee is blank in Whine emails"... I don't understand how that describes a solution rather than a problem. Can you give any guidance on what I'm missing?

Comment 6

8 years ago
(In reply to comment #5)
> Max, my original summary was "Assignee value missing from whine mails" which
> seems quite similar to me to the current "Assignee is blank in Whine emails"...
> I don't understand how that describes a solution rather than a problem. Can you
> give any guidance on what I'm missing?

  Oh, you're indeed right, and I simply made an error here when I changed the field values. :-)

Comment 7

8 years ago
Created attachment 419265 [details] [diff] [review]
patch for 3.6, v2.1

Unbitrotten patch, due to bug 519142. I also removed the duplicated 'assigned_to' entry in whine.pl.
Attachment #395137 - Attachment is obsolete: true
Attachment #407776 - Attachment is obsolete: true
Attachment #419265 - Flags: review+
Attachment #407776 - Flags: review?(wicked)

Comment 8

8 years ago
Comment on attachment 395140 [details] [diff] [review]
patch against 3.4.1 using assignee real name in the mails

>-  Assignee: [%+ bug.$assignee_login_string %]
>+  Assignee: [%+ bug.assigned_to_realname %]

No reason to display the real name of assignees. We should keep login names.
Attachment #395140 - Flags: review?(wicked) → review-

Comment 9

8 years ago
Created attachment 419266 [details] [diff] [review]
patch for 3.4, v2

Backport of the patch for 3.6.
Attachment #395140 - Attachment is obsolete: true
Attachment #419266 - Flags: review+

Comment 10

8 years ago
Leaving Kent as the assignee as I simply removed bitrot.
Status: NEW → ASSIGNED
Flags: blocking3.6+
Flags: approval3.4+
Flags: approval+

Comment 11

8 years ago
tip:

Checking in whine.pl;
/cvsroot/mozilla/webtools/bugzilla/whine.pl,v  <--  whine.pl
new revision: 1.41; previous revision: 1.40
done
Checking in template/en/default/whine/mail.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/whine/mail.html.tmpl,v  <--  mail.html.tmpl
new revision: 1.10; previous revision: 1.9
done
Checking in template/en/default/whine/mail.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/whine/mail.txt.tmpl,v  <--  mail.txt.tmpl
new revision: 1.10; previous revision: 1.9
done


3.4.4:

Checking in whine.pl;
/cvsroot/mozilla/webtools/bugzilla/whine.pl,v  <--  whine.pl
new revision: 1.38.2.2; previous revision: 1.38.2.1
done
Checking in template/en/default/whine/mail.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/whine/mail.html.tmpl,v  <--  mail.html.tmpl
new revision: 1.7.4.1; previous revision: 1.7
done
Checking in template/en/default/whine/mail.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/whine/mail.txt.tmpl,v  <--  mail.txt.tmpl
new revision: 1.7.4.1; previous revision: 1.7
done
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.