Closed Bug 511217 Opened 13 years ago Closed 13 years ago

File is getting overwritten with mobwrite contents

Categories

(Skywriter Graveyard :: Collaboration, defect, P1)

0.4.1
Other
Other
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dangoor, Assigned: jwalker)

Details

When I loaded up Bespin, I was in Joe's shared example document on 
bespin.mozilla.com. I tried to switch to another file (uvc/README.txt), and the 
contents displayed were the collab contents that I had been viewing previously. 
I switched to one of the .py files in that directory and they loaded just fine. 
Going back to the README file, I again saw the contents of the example file.

I don't see a mobwrite directory for uvc:
/bespinfiles/fsroot/c/4/1/3/c41330a5-bb0d-42d4-a806-233bbf4f519f

"vcs status" confirmed that the README file had changed.
"vcs revert" put the file back, but loading the README file *still* continued 
to show the collab contents, rather than the example file.

This is using the collab code from the 0.4.1 tag.
Target Milestone: --- → 0.4.2
Priority: -- → P1
It is possible that this was fixed in the process of other changes that Joe 
made. I have not been able to reproduce this today.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Reopening. I was able to reproduce it just now...

From IRC:

1. opened up yorkshire kdangoor @ 11:05
2. select all 11:05
3. paste 11:05
4. beach ball of doom 11:05
5. firefox came back 11:05
6. "collaboration error" 11:05
7. use file explorer to open index.html in your shared project 11:06
8. contents of yorkshire are displayed
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Target Milestone: 0.4.2 → 0.4.3
i'm fairly sure this had nothing to do with collaboration - the problem was that we were saving the files contents if they were dirty, but saving them to the new file location rather than the old one.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.