Closed Bug 511678 Opened 11 years ago Closed 11 years ago

keyboard shortcut Ctrl+Shift+M should invoke "compose mail" in alternate mode

Categories

(SeaMonkey :: MailNews: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: e_fax_t, Unassigned)

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1

Ctrl+M is the keyboard shortcut to start composing a new message using the default mode (html or text) as defined in the server's settings. Shift-clicking the "compose" button will invoke the message editor in the alternate (non-default) mode, hence it would be logical to get that behaviour when hitting Ctrl+Shift+M as well.

Reproducible: Always
Although it won't work on Mac, we should do it for Linux/Win/etc.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Tested on WinXP. Unfortunately I can't test on Linux nor on OSX.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #416250 - Flags: review?(mnyromyr)
+    <key id="key_newMessage"
+         key="&newMessageCmd.key;"
+         modifiers="accel,shift"
+         command="cmd_newMessage"/>
+    <key id="key_newMessage2"
+         key="&newMessageCmd.key;"
+         modifiers="accel,shift"
+         command="cmd_newMessage"/>

Does it work if you only put the keys in the platform-specific overlays and not the xplatform ones?
> Does it work if you only put the keys in the platform-specific overlays and not
> the xplatform ones?

If you mean leave the changes out of mailNavigatorOverlay.xul, then the answer is probably, since I am unable to test on a Mac. This version of the patch does work on WinXP.
Attachment #416250 - Attachment is obsolete: true
Attachment #416905 - Flags: review?(mnyromyr)
Attachment #416250 - Flags: review?(mnyromyr)
Attachment #416905 - Flags: review?(stefanh)
I ment like this: You have 1 key that should be on all platforms, then one extra key that you want on win/nix. So, what I ment to suggest was using <keyset id="tasksKeys"> for overlaying the extra key in win/nix overlays, but leaving out the mac overlay.
> I meant like this: You have 1 key that should be on all platforms, then one
> extra key that you want on win/nix. So, what I meant to suggest was using
> <keyset id="tasksKeys"> for overlaying the extra key in win/nix overlays, but
> leaving out the mac overlay.

OK. Understood.
Attachment #416905 - Attachment is obsolete: true
Attachment #417435 - Flags: review?(mnyromyr)
Attachment #416905 - Flags: review?(stefanh)
Attachment #416905 - Flags: review?(mnyromyr)
Attachment #417435 - Flags: review?(stefanh)
I'm sorry. I really had hoped after our first IRC conversation about this that you wouldn't put more/too much effort into it. :-(

Because, in the light of the recent Lightning shortcut debacle, it clearly showed that keyboard shortcuts are a very precious, very scarce resource indeed. 
We should not waste it on duplicating functionality which will be used only rarely.

So, contrary to my comment #1, I regard this now as WONTFIX.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Attachment #417435 - Flags: review?(stefanh)
Attachment #417435 - Flags: review?(mnyromyr)
Assignee: philip.chee → nobody
You need to log in before you can comment on or make changes to this bug.