Last Comment Bug 511762 - Unwanted horizontal scrollbars on http://diveintohtml5.org/
: Unwanted horizontal scrollbars on http://diveintohtml5.org/
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 539698
Blocks: 445087 498428
  Show dependency treegraph
 
Reported: 2009-08-20 15:18 PDT by Sylvain Pasche
Modified: 2012-02-02 03:48 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (168.03 KB, text/html)
2009-08-20 15:18 PDT, Sylvain Pasche
no flags Details

Description Sylvain Pasche 2009-08-20 15:18:32 PDT
Created attachment 395690 [details]
testcase

If you go to http://diveintohtml5.org/, you'll notice horizontal scrollbars in the table of content. This is a regression from bug 498428.
More specifically, it comes from the non-upstream patch http://mxr.mozilla.org/mozilla-central/source/gfx/cairo/win32-cleartype-clipping.patch introduced in bug 445087.

Apparently, it only happens when using a web font (lin-libertine-min.ttf in the testcase).
Comment 1 Timothy Nikkel (:tnikkel) 2010-04-04 19:11:23 PDT
This also happens with the default font in the bugzilla comment box if the length of the line is just right and in the facebook chat text entry box where it is quite annoying because the box is only one line high and the scrollbar blocks the text.
Comment 2 JP Rosevear [:jpr] 2012-02-02 03:48:44 PST
The test case does not show a scroll bar on linux and related bugs are all fixed.  Assuming fixed, please re-open if not.

Note You need to log in before you can comment on or make changes to this bug.