Closed Bug 511913 Opened 12 years ago Closed 12 years ago

Windows Firefox overflow:auto in tbody or div truncates large data set tables

Categories

(Firefox :: General, defect)

3.5 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: alex.rosekrans, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

If I have a table and the tbody has a style="overflow:auto"  it stops rendering rows between 1300 and 1400 rows.

I have the latest firefox.  This was caught with the previous version as well.

Reproducible: Always

Steps to Reproduce:
1. Load a page with the HTML coded to have a large amount of rows that has an overflow:auto in the tbody tag or an encapsulating div tag.
2. Scroll down until you see that the table is truncated.
3. Scroll to the bottom of the page, or until it is obvious that you have come to the end of the space designated for the broken table
Actual Results:  
A broken table that is truncated 

Expected Results:  
A table that shows all the rows

here is a php script to generate html that will reproduce this:

<?PHP
$stringHTML = "<html><body><table style='background-color:#00AA00'>
<tbody style=\"overflow:auto\"> <!-- change to hidden in order to correct the truncation -->";

$i = 0;
while ($i < 1500)
{
	$stringHTML .= "<tr><td>Test Row {$i}</td></tr>\n";
	$i++;
}
$stringHTML .= "</tbody></table></body></html>";

echo $stringHTML;
?>
Attached file Test case
Attached file Test Case 2
same issue with the overflow:auto, except with the div tag instead of the tbody tag
Version: unspecified → 3.5 Branch
This has been fixed in the current development builds and will be in Firefox 3.6.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.