Incorrect cursor positioning , while using drag and drop

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Vish, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090810 Ubuntu/9.10 (karmic) Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090810 Ubuntu/9.10 (karmic) Firefox/3.5.2

Problem is seen during:
1: Drag-and-drop of text in a text field [eg: comments box]
2: Drag-and-drop while organizing bookmarks 

Reproducible: Always

Steps to Reproduce:
A: Drag and drop of text in a text field [eg: comments box]
For single-line text input boxes
1. Type and Select text 
2. Now drag the text
3. Cursor is missing

For text input boxes which have several lines [eg: comments box]
1. Type text for several lines > 4 lines
2. Select text in the First line
3. Now drag the text in the First line
4. Cursor is missing
5. Now drag the text , from the first line , lower so that the mouse pointer is now on the 4th line
6. notice the cursor in the first line !

While organizing bookmarks:
1. select bookmark and drag it
2. Drag it over to the Left pane , to drop in a folder
3. Notice the cursor position is always higher than the pointer [about 2-3 lines higher]
Actual Results:  
For single line text boxes and large input boxes:
The cursor is missing when the pointer is in the first line 
and cursor is visible in first line only when the pointer in brought much lower.

For bookmarks:
Cursor is always higher than the pointer position. which leads to improper drops

Expected Results:  
Cursor should always be positioned near the pointer. 
Only this will allow easier and predictable drag-and-drop.

When dragging tabs , this also leads to tearing off of the tab and new windows are opened > https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/413950/comments/4

These behavior is noticed only in firefox and thunderbird apps , in all other apps position the cursor is always near the pointer.

This did not happen in the previous versions of the apps.

I'v also tested with
- mozilla build of 3.5.2 and 
- Ubuntu 3.7 version of firefox[ppa], the issue is present in all the versions.

Lp firefox bug > https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/413950
Lp thunderbird bug > https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/403325

Also to note : 
when the bookmarks are dragged within the right pane or when dragged in the bookmarks drop-down menu , the cursor is positioned correctly [near the pointer]

Comment 1

9 years ago
Reed added per Alexander Sack
Changing to Drag and Drop...
Component: Layout: Text → Drag and Drop
QA Contact: layout.fonts-and-text → drag-drop

Comment 3

9 years ago
I see this happen in Thunderbird when moving mails. but only if the folder pane has been scrolled at leasrt once after startup.

Comment 4

9 years ago
All people affected by this seem to have been users of Ubuntu karmic development releases. Since a few weeks before the release, this was fixed at least for me in Ubuntu 9.10. I wonder if it is still affecting anyone...
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> All people affected by this seem to have been users of Ubuntu karmic
> development releases. Since a few weeks before the release, this was fixed at
> least for me in Ubuntu 9.10. I wonder if it is still affecting anyone...

I'm the original reporter of this bug , The bug seems solved for me. But oddly *not* fixed by an update in firefox. 
Seems that something else was affecting firefox and thunderbird simultaneously.

Comment 6

9 years ago
Yes, I assume it was an Ubuntu-related problem, so IHMO this bug could be set to RESOLVED/WORKSFORME (My bugzilla account seems not to allow this change).
Resolving as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.