Closed Bug 511987 Opened 11 years ago Closed 10 years ago

Fennec doesn't load Amazon Recent History div after scrolling

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect, P1)

defect

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: mikecpchen, Assigned: stechz)

References

()

Details

(Whiteboard: [fennecb3testday])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 XPCOMViewer/0.9a
Build Identifier: 1.9.2a2pre

When accessing www.amazon.com, the bottom of the page "Your Recent History" was never rendered. The turning wheel continues to show that the rendering is in process.

Reproducible: Always

Steps to Reproduce:
1. Type www.amazon.com in URL
2. Scroll down to the bottom of the page
3. Look for "Your Recent History" iFrame.


Expected Results:  
The browser should fetch information and render the contents for Recent History from the web server.
Confirmed on builds:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090821
Fennec/1.0b3pre

and

Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.5; en-US; rv:1.9.2a2pre)
Gecko/20090808 Fennec/1.0b3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-fennec1.0?
Whiteboard: [fennecb3testday]
should this be in 1.0?
tracking-fennec: --- → ?
Priority: -- → P1
There's no iframe involved.  This is a div that gets loaded based on a JQuery onReady handler.  I'm not sure what JS event isn't being thrown here -- I suspect it's something to do with this area being made visible to the user, since Amazon normally doesn't load this until it's scrolled to.
Summary: Fennec fails to render page contents for iFrame → Fennec doesn't load Amazon Recent History div
It looks like the Amazon JS code is installing a scroll handler.  On every scroll, it looks to see if the Recent History div is visible, and if it is, it starts the load of the content for this div.  Since we're not firing scroll events when panning the page, this code doesn't get run.

On the source for amazon.com, search for "var rhfShvlEventHandler".  This gets registered as a $(window).scroll handler in the code that gets run once JQuery has loaded.
why aren't we firing scroll events for content when panning?
Because scrolling the content would fire paint events that would invalidate all of the tiles, slowing down scrolling.  We tried this to get fixed position elements moving correctly, and it was quite slow.
tracking-fennec: ? → 1.0-
renominating this for blocking-fennec.  still repros on 20100510 nightly build
tracking-fennec: 1.0- → ?
Interesting effect: when you click a link on the amazon.com page, after you've scrolled down, and then go back, the recent history div gets loaded.
So apparently, by going back into history, a scroll event is fired somewhere.
Component: General → Panning/Zooming
QA Contact: general → pan-zoom
Summary: Fennec doesn't load Amazon Recent History div → Fennec doesn't load Amazon Recent History div after scrolling
Assignee: nobody → webapps
tracking-fennec: ? → 2.0b1+
Depends on: 576192
seems fixed by bug 576192
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Yep, verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre

I'm getting a lot of "Operation temporarily disabled due to low memory on Maemo. Will file that in a separate bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.