Firefox displays font colors incorrect with ClearType turned on in Vista x64

RESOLVED DUPLICATE of bug 363861

Status

()

--
major
RESOLVED DUPLICATE of bug 363861
9 years ago
2 years ago

People

(Reporter: kayoss120, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

when ClearType is enabled in Vista x64, Firefox 3.5.2 displays some font colors wrong when opacity is used.

forum thread discussing the problem:
http://forums.mozillazine.org/viewtopic.php?f=38&t=1414815

a somewhat similar old bug is here:
https://bugzilla.mozilla.org/show_bug.cgi?id=363861

html page showing the problem:
https://bug363861.bugzilla.mozilla.org/attachment.cgi?id=321706

another screenshot showing the problem:
https://bug363861.bugzilla.mozilla.org/attachment.cgi?id=396127

Reproducible: Always

Steps to Reproduce:
1. enable ClearType in Vista x64
2. run Firefox 3.5.2
3. look at this page: https://bug363861.bugzilla.mozilla.org/attachment.cgi?id=321706
Actual Results:  
font colors look messed up

Expected Results:  
font colors should not look messed up
(Reporter)

Comment 1

9 years ago
With font smoothing disabled or set to Standard, the problem doesn't happen.

by the way, here's how to find the font smoothing options in vista:
control panel --> personalization --> window color and appearance --> open classic appearance properties for more color options --> click on "Effects"

Comment 2

9 years ago
It doesn't just effect opacity. Check out http://www.mobify.me/ for a real world example. The "Learn More" text has an opacity set for .9999, but the upper right hand "Sign-up" doesn't. Changing color to other then white (via firebug) helps. To see it even better, turn off backgrounds with firebug.

Using Vista 64 with ClearType, FF 3.5.5 and FF 3.6 beta.

Comment 3

9 years ago
I noticed that the growl like new mail notification on Thunderbird 3.0b4 has the strangely colored anti aliasing too.

Comment 4

9 years ago
This build (http://www.osnews.com/comments/22543) of "Firefox 3.7 with built-in Direct2D acceleration" seems to have fixed the issue (uses different font renderer?). I was suspecting some sort of hex math rounding issue, or using the full number instead of each channel's number separately.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363861

Updated

9 years ago

Updated

9 years ago
You need to log in before you can comment on or make changes to this bug.