Closed Bug 512171 Opened 15 years ago Closed 13 years ago

crash [@ nsWindowSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, int, int*, int*)]

Categories

(Core :: XBL, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking1.9.1 --- -

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash, topcrash, Whiteboard: [tbird crash])

Crash Data

crash nsWindowSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, int, int*, int*)

This crash exists on both Thunderbird and Firefox. the only useful comment via extensive search of TB crashes is related to checking extension compatibility

TB
bp-30f09b3d-65c0-4211-9f23-136112090203
3.0b2pre      20090131031232     
bp-d4bb2592-4473-46a4-b152-a0a012090719
3.0b2      20090223175111
*checking compatibility of add-ons*
0    thunderbird.exe    nsWindowSH::GetProperty     dom/src/base/nsDOMClassInfo.cpp:4707
1    thunderbird.exe    XPC_WN_Helper_GetProperty js/src/xpconnect/src/xpcwrappednativejsops.cpp:957
2    js3250.dll    js_NativeGet    js/src/jsobj.cpp:3739
3    js3250.dll    js_Interpret    js/src/jsinterp.cpp:5133
4    js3250.dll    js_Invoke    js/src/jsinterp.cpp:1334
5    js3250.dll    js_InternalInvoke    js/src/jsinterp.cpp:1391
6    js3250.dll    JS_CallFunctionValue    js/src/jsapi.cpp:5265
7    xpcom_core.dll    nsQueryInterfaceWithError::operator    nsCOMPtr.cpp:75
8    thunderbird.exe    nsXBLBinding::ExecuteDetachedHandler content/xbl/src/nsXBLBinding.cpp:983
9    thunderbird.exe    nsBindingManager::ExecuteDetachedHandlers content/xbl/src/nsBindingManager.cpp:1041


TB 3.0b3pre
bp-41f4c1b8-14a8-4341-9f36-2e1c52090712
0    thunderbird.exe    nsWindowSH::GetProperty     dom/src/base/nsDOMClassInfo.cpp:4753
1    thunderbird.exe    XPC_WN_Helper_GetProperty js/src/xpconnect/src/xpcwrappednativejsops.cpp:960
2    js3250.dll    js_GetSprop    js/src/jsscope.h:378
3    js3250.dll    js_NativeGet    js/src/jsobj.cpp:4166
4    js3250.dll    js_Interpret    js/src/jsinterp.cpp:5310
5    js3250.dll    js_Invoke    js/src/jsinterp.cpp:1394
6    js3250.dll    js_InternalInvoke    js/src/jsinterp.cpp:1447
7    js3250.dll    JS_CallFunction    js/src/jsapi.cpp:5187
8    xpcom_core.dll    nsQueryInterfaceWithError::operator objdir-tb/mozilla/xpcom/build/nsCOMPtr.cpp:75
9    thunderbird.exe    nsXBLBinding::ExecuteDetachedHandler content/xbl/src/nsXBLBinding.cpp:985
10    thunderbird.exe    nsBindingManager::ExecuteDetachedHandlers content/xbl/src/nsBindingManager.cpp:1041 

FF
bp-d33774ff-ffbd-416a-b101-6a36a2090129
3.2a1pre      20090128034731
bp-224214d5-3685-4900-9f03-fa7822090128
3.1b3pre      20090128041432
Flags: blocking-thunderbird3?
ref bug 395707
Based on comment 0, this looks like a core bug. Based on the one comment about checking extension compatibility I'm going to put this in addons, but please feel free to move elsewhere if someone can work out a more appropriate component.
Component: General → Add-ons Manager
Product: Thunderbird → Toolkit
QA Contact: general → add-ons.manager
Component: Add-ons Manager → XBL
Flags: blocking-thunderbird3?
Product: Toolkit → Core
QA Contact: add-ons.manager → xbl
Summary: crash nsWindowSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, int, int*, int*) → crash [@ nsWindowSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, int, int*, int*)]
blocking1.9.1: --- → ?
Not going to block on this. It's not a topcrash for Firefox. We'll consider a patch though.
blocking1.9.1: ? → -
rechecked topcrash - it is #7 for thunderbird 3.0b3. definitely related to extensions...

almost no comments out of several TB and FF thousand crashes - a couple mention shutdown and startup, and  

bp-d4bb2592-4473-46a4-b152-a0a012090719 has "checking compatibility of add-ons"

bp-247aff7c-aef3-4dcc-b742-817612090823 "Add-ons: {CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}:6.0.11,{CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}:6.0.13,jqs@sun.com:1.0,orbit_ffext@orbitdownloader:2.02,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.5.2,{e213bb8f-8ebd-11db-96b7-005056c00008}:3.0.0.56 BuildID: 20090729225027 CrashTime: 1251024526 InstallTime: 1249386121 ProductName: Firefox SecondsSinceLastCrash: 17 StartupTime: 1251024526 Theme: classic/1.0 Throttleable: 1 URL: Vendor: Mozilla Version: 3.5.2 bu ne kardeşim ya her zaman
Whiteboard: [tbird crash]
I also got this during shutdown.  The only extension I have enabled right now is DOM Inspector.
Kurt, if you disable DOM Inspector, do you still see the shutdown crash?
That is the only time I've gotten that crash in the last three months and I'm not even sure what I did when I got that crash.  I know I was playing with a test case that causes my system to hang, Firefox finally accepted my command to close via the close button and then I got that report.  I haven't been able to reproduce the crash.
#44 crash for v3.0.4.
still alive and well in firefox trunk nightlies - the most recent build being 20100421. PMed 7 Fx and TB users
(In reply to comment #8)
> #44 crash for v3.0.4.
> still alive and well in firefox trunk nightlies - the most recent build being
> 20100421. PMed 7 Fx and TB users
I was seeing this crash on shutdown after I had what appeared to be a hang in the UI (turns out it was a conflict with flash (when ipc was enabled) and directwrite/direct2d.
I just got this crash with Nightly Minefield Build 20100506040636. Win7 Pro x64, HTML5=on, OOPP=on, D2D=on, DW=on.

http://crash-stats.mozilla.com/report/index/7816011a-8106-474f-b04c-b3a2d2100506
http://crash-stats.mozilla.com/report/index/d260956e-3bf1-4b8f-bfbc-e058a2100520

Crashes on mint.com when I go to see a flash based graph for investments. Doesn't crash with IPC disabled.
(In reply to comment #11)
> Crashes on mint.com when I go to see a flash based graph for investments.
> Doesn't crash with IPC disabled.
This is also how I saw it.
Do we need a separate bug on the oopp thing?  That couldn't possibly date back to 2009-08-23 like this bug does!
Blocks: OOPP
Well, I'm a n00b with no Mozilla programming skills, but I think it would depend on whether this is a bug that should've been fixed and is now exposed more by enabling OOPP. Or... something completely new directly OOPP related in which case a new bug would seem appropriate.
Crash Signature: [@ nsWindowSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, int, int*, int*)]
this crash sig ends starting with the thunderbird 3.1.x line.
and for firefox, not seen after 4.0b2
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.