canvas arcTo() implementation is incorrect

RESOLVED DUPLICATE of bug 471281

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 471281
8 years ago
8 years ago

People

(Reporter: Klaus Förster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

According to the Canvas specification, the current implementation of arcTo(x1, y1, x2, y2, radius) in Firefox 3.5 is incorrect.

The specification states: "The method must connect the point (x0, y0) to the start tangent point by a straight line, adding the start tangent point to the subpath, and then must connect the start tangent point to the end tangent point by The Arc, adding the end tangent point to the subpath."

Given this text, the arc should end at the end tangent point t2 and not reach further to x2/y2.

SpecLink: http://www.whatwg.org/specs/web-apps/current-work/multipage/the-canvas-element.html#dom-context-2d-arcto

Reproducible: Always

Steps to Reproduce:
1. Open URL demonstrating the problem 
2. the right image shows correct rendering
3. the left image shows actual rendering
Actual Results:  
The arc in the left image ended at point x2/y2

Expected Results:  
The arc in the left image should end at point t2
WFM on OS X trunk. Left and right are identical, line ends at t2.
Component: General → Layout: Canvas
Product: Firefox → Core
QA Contact: general → layout.canvas

Comment 2

8 years ago
Bug 471281 ?

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471281
You need to log in before you can comment on or make changes to this bug.