Port |Bug 506985 - remove java-specific preferences from Firefox UI, hidden prefs| to SeaMonkey 2.1

RESOLVED FIXED in seamonkey2.5

Status

SeaMonkey
Preferences
--
trivial
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: ewong)

Tracking

({useless-UI})

Trunk
seamonkey2.5
useless-UI
Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.1 wontfix, seamonkey2.2 affected, seamonkey2.3 fixed, seamonkey2.4 fixed)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Remove obsolete preference (code).
Flags: in-testsuite-
(Reporter)

Comment 1

8 years ago
This can wait until c-c branches.
No longer blocks: 470184
Depends on: 470184
Target Milestone: --- → Future
(Reporter)

Updated

8 years ago
Depends on: 521624
No longer depends on: 470184
(Reporter)

Updated

7 years ago
Depends on: 535594
Target Milestone: Future → ---
(Assignee)

Comment 2

6 years ago
Serge, 2.1 has been released.  Which branch should this be ported for?
(Reporter)

Comment 3

6 years ago
Summary:

*SeaMonkey skipped *-1.9.2.
*SeaMonkey 2.1 has been released: marking as WontFix there.
*SeaMonkey 2.2+ still want this, unless branch is already code frozen.

Remember to remove the 2 strings in non string frozen branches too:
http://mxr.mozilla.org/comm-central/search?string=enbJavaCheck.&case=1&find=%2Fsuite%2F
status-seamonkey2.1: --- → wontfix
Keywords: useless-UI
Whiteboard: [good first bug]

Comment 4

6 years ago
2.2 is string frozen
2.3 will be in the next week or so once 2.2 comes out
(Assignee)

Updated

6 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 5

6 years ago
Created attachment 544990 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs.
Attachment #544990 - Flags: review?
(Assignee)

Updated

6 years ago
Attachment #544990 - Flags: review? → review?(iann_bugzilla)
(Reporter)

Comment 6

6 years ago
Comment on attachment 544990 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs.

Review of attachment 544990 [details] [diff] [review]:
-----------------------------------------------------------------

Clean /suite/profile/migration/src/ns*ProfileMigrator.cpp up too.

::: suite/locales/en-US/chrome/common/pref/pref-advanced.dtd
@@ +1,5 @@
>  <!--LOCALIZATION NOTE : FILE 'Advanced' prefs settings -->
>  <!ENTITY pref.advanced.title        "Advanced">
>  
>  <!ENTITY prefEnableJava.caption     "Features that help interpret web pages">
>  

Remove lines 4-5 too.
Attachment #544990 - Flags: feedback-

Comment 7

6 years ago
Comment on attachment 544990 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs.

As Serge said, u missed a line from the .dtd file and there is also the profile migration files.
http://mxr.mozilla.org/comm-central/search?string=security\.enable_java&regexp=on&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
Should be just a matter of deleting the two lines that mention security.enable_java
Any help need updating too?
Attachment #544990 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 8

6 years ago
Created attachment 545039 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v2)
Attachment #544990 - Attachment is obsolete: true
Attachment #545039 - Flags: review?(iann_bugzilla)
(Reporter)

Comment 9

6 years ago
Comment on attachment 545039 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v2)

Maybe "<p>The main Advanced preferences panel allows you to ..." should be kept, but updated to something more generic (= up-to-date at least)?
Attachment #545039 - Flags: feedback+
(Reporter)

Comment 10

6 years ago
Comment on attachment 545039 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v2)

>   <li class="unix"><strong>Use Preferences from System</strong>: Select this to
>     use the already set system preferences, overriding &brandShortName;&apos;
>     ones.

I don't have Linux, so I wonder: is this other pref (un)related to Java?

Comment 11

6 years ago
Comment on attachment 545039 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v2)

>+++ b/suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml
>@@ -46,23 +46,17 @@
>-<p>The main Advanced preferences panel allows you to enable or disable
>-  Java:</p>
Leave this in but change to <p class="unix"> and remove the "enable or disable Java" bit so it now reads:
<p class="unix">The main Advanced preferences panel allows you to:</p>

r=me with that sorted.
Attachment #545039 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 12

6 years ago
Created attachment 545158 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) [Checked in: Comment 13]
Attachment #545039 - Attachment is obsolete: true
Attachment #545158 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed

Comment 13

6 years ago
Comment on attachment 545158 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) [Checked in: Comment 13]

http://hg.mozilla.org/comm-central/rev/f7b16da534a1
Attachment #545158 - Attachment description: Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) → Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) [Checked in: Comment 13]

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [good first bug]
Target Milestone: --- → seamonkey2.5
Is this worth a) relnoting b) landing non-l10n changes on branches?

Updated

6 years ago
Duplicate of this bug: 672665
(In reply to comment #14)
> Is this worth a) relnoting

Sure, done (for 2.2 only, see next point).

> b) landing non-l10n changes on branches?

Having useless UI just adds confusion, so I'd vote for copying all changes except the pref-advanced.dtd ones to branches (given that Help changes are allowed as long as no files are added/removed/renamed).
Keywords: relnote

Comment 17

6 years ago
This is not fixed in SM 2.2; the preference, albeit inoperative, is still present and checking the UI checkbox toggles it between True and False. The result is a  security exposure; the naive user thinks Java is being Enabled and Disabled but the default Enabled cannot be changed using the preference, but only via the Add-ons Manager.
(In reply to comment #17)
> This is not fixed in SM 2.2

No-one said it was. The Target Milestone is currently SM 2.5 and it has been relnoted for SM 2.2 (granted, only yesterday, see comment 16). If it won't make SM 2.3 or SM 2.4, it will be relnoted for these, too.
Comment on attachment 545158 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) [Checked in: Comment 13]

Requesting permission to land everything but the pref-advanced.dtd changes on Aurora and Beta.
Attachment #545158 - Flags: approval-comm-beta?
Attachment #545158 - Flags: approval-comm-aurora?
Comment on attachment 545158 [details] [diff] [review]
Removed java-specific preferences from SeaMonkey UI and hidden prefs and help. (v3) [Checked in: Comment 13]

a+ provided the .dtd does not land.
Attachment #545158 - Flags: approval-comm-beta?
Attachment #545158 - Flags: approval-comm-beta+
Attachment #545158 - Flags: approval-comm-aurora?
Attachment #545158 - Flags: approval-comm-aurora+
http://hg.mozilla.org/releases/comm-aurora/rev/73eba6d39764
http://hg.mozilla.org/releases/comm-beta/rev/0a3ac1c46c65
Target Milestone: seamonkey2.5 → seamonkey2.3

Comment 22

6 years ago
No idea how you guys handle this, but this did change the localizable help files.
(In reply to comment #22)
> No idea how you guys handle this, but this did change the localizable help
> files.

Our policy is that Help changes are allowed as long as no files are added/removed/renamed (see comment 16).

Updated

6 years ago
status-seamonkey2.2: --- → affected
status-seamonkey2.3: --- → fixed
status-seamonkey2.4: --- → fixed
Target Milestone: seamonkey2.3 → seamonkey2.5
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.