subframes (e.g. iframe) not scrollable (example: google reader)

VERIFIED DUPLICATE of bug 511432

Status

Firefox for Android Graveyard
General
--
blocker
VERIFIED DUPLICATE of bug 511432
9 years ago
4 years ago

People

(Reporter: Uwe Kaminski, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Nightly build from 2009-08-23

I used the following files to install fennec:

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/xulrunner_1.9.3a1pre-20090824010608_armel.deb

and:

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/fennec_1.0b4pre_armel.deb


Reproducible: Always

Steps to Reproduce:
0. You should have a google account and put some feeds into the google reader because the starting page should contain more information than can be made visible on a 480px hight screen.
1. start fennec
2. go to http://google.com/reader
3. try to scroll the ifram on the right side of the screen

Actual Results:  
It's impossible to scroll the page

Expected Results:  
Page should be scrollable

There is a bug for this but I don't have the rights to reopen it:
https://bugzilla.mozilla.org/show_bug.cgi?id=458741

Please reopen it and mark this bug as an duplicate
(Reporter)

Updated

9 years ago
Depends on: 458741
The patch was pushed on 7/29 and I did a verification on it on 9/22. After trying this out on google reader today (after the verification on 9/22), this regressed.

confirmed on build:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091008
Fennec/1.0b4
Severity: major → blocker
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
The patch you mention was for iframe/frames.  Google Reader uses overflow divs, and that problem is tracked in bug 511432
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511432
Ah, verified dupe.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
OS: All → Linux (embedded)
Hardware: All → ARM
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.