There should be option for tab drag-and-drop opening a new window

RESOLVED DUPLICATE of bug 489729

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 489729
9 years ago
9 years ago

People

(Reporter: Ihar 'Philips' Filipau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

With Fx3.x, new feature came in which allows Tab to be drag-and-dropped outside of tab bar. After that, Fx opens a new browser window with the tab, while in originating window the tab is removed.

This is at times (when one has to work with lots of tabs) confusing feature, because a quick click on the tab to activate it, might be not precisely a click but press, drag, release.

Before that was harmless.

Now that leads to the effect that time-after time instead of activating a tab, I get the tab in a new window.

Most annoying part is that it's impossible to undo the operation. If I for example browse 20 pages open in tabs in chronological order and tab was moved to another window, finding original position of the tab is very time consuming.

Reproducible: Always

Steps to Reproduce:
1. Press mouse button on a tab.
2. Move mouse some pixels down
3. Release mouse
Actual Results:  
Tab is moved to a new browser window.

Expected Results:  
Nothing should have happened. Or whatever happened should be 'Undo'-able.

Option A: Tab opens in a new window, but then FireFox should offers an "Undo" function for the action.

Option B: Increase the dragging distance (or provide about:config tunable) used to recognize that user wants to open the tab in a new window

Option C: Provide an option to disable the tab tear-off altogether.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489729
You need to log in before you can comment on or make changes to this bug.