Remove REQUIRES from comm-central

RESOLVED FIXED

Status

defect
--
trivial
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: Callek)

Tracking

Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

10 years ago
Like bug 398573 comment 9.

It looks like this could be done already, but it can/could wait for c-c to branch first.

KaiRo, could you check and confirm the bug?
(Iirc, I'm thinking about some /mailnews/* build oddities, but don't think there are related, are they?)

Banjamin, if confirmed, could you "automatically" generate the patch for c-c too?
Flags: in-testsuite-
Reporter

Comment 1

10 years ago
s/Banjamin/Benjamin/

Comment 2

10 years ago
Posted file The script
Here's the script I used to automatically remove REQUIRES lines:

export PYTHONPATH=/mozilla-central/build/pymake
cd /comm-central
find . -name Makefile.in | xargs python remove-requires.py > remove-requires.patch

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 3

10 years ago
(Untested, but trivial.)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #396642 - Flags: review?(kairo)

Comment 4

10 years ago
Serge, please test this with a 1.9.1-based tree, I don't want to review something I don't know will work there, esp. as we're nearing the next round of betas for both products.
Reporter

Updated

10 years ago
Depends on: 512696
Reporter

Comment 5

10 years ago
(In reply to comment #4)

Sure, I just (wrongly) took Benjamin's confirmation of this bug as a ready to do...

I tried to build with m-1.9.1:
1- 1st failure made me file bug 512696.
2- then build failed in /mailnews/base/*.

Then I tried with m-c:
3- fails in /mailnews/base/* too.

Maybe c-c needs more of bug 496236 before doing this?
Depends on: C191ConfSync
Reporter

Updated

10 years ago
Whiteboard: [See comment 5]
Target Milestone: --- → Future
Reporter

Updated

10 years ago
Attachment #396642 - Flags: review?(kairo)
Reporter

Updated

10 years ago
Depends on: 513032
Reporter

Updated

10 years ago
Depends on: C192ConfSync
No longer depends on: C191ConfSync
Reporter

Updated

9 years ago
Depends on: 488175
Target Milestone: Future → ---
Reporter

Comment 6

9 years ago
(In reply to comment #5)
> Maybe c-c needs more of bug 496236 before doing this?

I'll try again after bug 488175 port lands.
Reporter

Updated

9 years ago
Depends on: 513921
Reporter

Updated

9 years ago
Depends on: 517097
Assignee

Comment 7

9 years ago
This should do it; and should be safe to take now.
Assignee: sgautherie.bz → bugspam.Callek
Attachment #396642 - Attachment is obsolete: true
Attachment #450824 - Flags: review?(kairo)
Assignee

Updated

9 years ago
Attachment #450824 - Attachment is patch: true
Attachment #450824 - Attachment mime type: application/octet-stream → text/plain

Comment 8

9 years ago
Comment on attachment 450824 [details] [diff] [review]
Bv1 - Updated. Automatic Removes + autoconf.mk

I cannot test a successful build because static builds are broken, but as my breakage is the known one, I guess your patch is OK :)
Attachment #450824 - Flags: review?(kairo) → review+
Comment on attachment 450824 [details] [diff] [review]
Bv1 - Updated. Automatic Removes + autoconf.mk

These files will all have empty if*def statements with this patch:

mail/components/build/Makefile.in
mailnews/base/build/Makefile.in
mailnews/build/Makefile.in
mailnews/compose/src/Makefile.in
mailnews/import/build/Makefile.in
mailnews/mime/src/Makefile.in

These files could do with extra blank lines removing after REQUIRES has been removed from ifdefs:

mailnews/addrbook/src/Makefile.in
mailnews/base/src/Makefile.in (2 places)
mailnews/build/Makefile.in
Assignee

Comment 10

9 years ago
Porting KaiRo's r+. Requesting additional r from Mark.
Attachment #450824 - Attachment is obsolete: true
Attachment #451204 - Flags: review?(bugzilla)
Assignee

Updated

9 years ago
Attachment #451204 - Flags: review+
Comment on attachment 451204 [details] [diff] [review]
Cv2 - Clean some more stuff too
[Checked in: Comment 12]

That's better, thanks.
Attachment #451204 - Flags: review?(bugzilla) → review+
Assignee

Comment 12

9 years ago
Well accidentally pushed tonight, but o well; it had reviews:
http://hg.mozilla.org/comm-central/rev/eacc929ccc27
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [See comment 5]
Reporter

Updated

8 years ago
Attachment #451204 - Attachment description: Cv2 - Clean some more stuff too. → Cv2 - Clean some more stuff too [Checked in: Comment 12]
Reporter

Updated

8 years ago
Blocks: 512696
No longer depends on: 512696
Reporter

Updated

8 years ago
Depends on: 717736
You need to log in before you can comment on or make changes to this bug.