OS/2 don't link against external libs that are stubs when the real function is in libc

VERIFIED FIXED in mozilla1.9.3a1

Status

defect
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: wuno, Assigned: wuno)

Tracking

Trunk
mozilla1.9.3a1
x86
OS/2
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1.2) Gecko/20090802 Firefox/3.5.2
Build Identifier: 

Dave stated in bug511945 c#6 that linking against (lib)dl and (lib)socket and all the math stuff (e.g. (lib)m) is not necessary as all the functions needed are provided by libc. In my tree I removed all occurrences like -lsocket -ldl and -lm and got a well running browser, even flash 7R14 worked.
We should remove these dependencies, because they make trouble in bug511945 and might make trouble in the future. Particularly since we probably do not gain anything from them. 


Reproducible: Always
Dave, since your patch attached to bug511945 isn't the real solution for that bug, I'd like to ask you to attach it here (can you attach a CVS patch? If not I can do it for you).
I'll attach a patch for the main tree and js/src.
Version: unspecified → Trunk
Assignee: nobody → wuno
Status: NEW → ASSIGNED
Attachment #396481 - Flags: review?(mozilla)
forgot to sync js/src/configure.in after editing a comment in configure.in
Attachment #396481 - Attachment is obsolete: true
Attachment #396487 - Flags: review?(mozilla)
Attachment #396481 - Flags: review?(mozilla)
Walter, I believe I have created this patch according to the guidelines, if not can you recreate it and tell me the correct command.
Attachment #396641 - Flags: review?(mozilla)
IIRC, nspr and nss patches should be attached as diff's against CVS HEAD of nspr/nss. I updated my nspr tree to HEAD applied Dave's hg patch and rediffed using cvs -d -p -u8.
Comment on attachment 396487 [details] [diff] [review]
corrected version

Yes, this should be OK. Although in principle, I think, one should have different patches for the main mozilla-central build stuff and stuff in js/.
Attachment #396487 - Flags: review?(mozilla) → review+
Attachment #396641 - Flags: review?(mozilla)
Comment on attachment 396641 [details] [diff] [review]
Remove libldl and libsocket from nsprpub/configure.in

While I'm sure this is OK, NSPR stuff really needs to go into a separate bug (and then wtc should review it).
I won't have time to check this in...
Keywords: checkin-needed
Attachment #396641 - Attachment is obsolete: true
Attachment #396681 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/582caefb4cf1
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a1
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.