Closed Bug 512537 Opened 10 years ago Closed 3 years ago

Flip org.w3c.svg.static to be a supported feature

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jwatt, Unassigned)

References

()

Details

Annoyingly, the test:

  http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-struct-image-02-b.html

depends on the feature string "org.w3c.svg.static" being a supported feature.
This is still an issue as of the SVG 1.1SE test suite (although the specific testcase URL changed [1]). In the scope of SVG 1.1, this is probably a bug in the test suite which should be raised with the SVG WG (so that the test uses an SVG 1.1 feature string instead).

Thing is: I never quite understood why Mozilla doesn't report any [1] SVG 1.0 feature strings as supported (just checked with the stable version and a nightly build). If SVG 1.1, the current implementation target, is basically a superset of SVG 1.0, IMHO all applicable SVG 1.0 feature strings should be flipped to be supported. AFAIK, that's what WebKit, Opera, Batik and even IE9 are currently doing (just confirmed with a quick test visiting [2] with them).

Is there any rationale behind not reporting SVG 1.0 feature strings as supported? If so, what would be the argument in order to flip a specific feature string just to pass the SVG 1.1 test suite? If not, I'd hint towards reworking this issue to be "Flip all applicable SVG 1.0 feature strings to be supported" or create a new one which this issue would depend on. :-)

[1] http://dev.w3.org/SVG/profiles/1.1F2/test/harness/htmlObject/struct-image-02-b.html
[2] http://codedread.com/svgtest.svg
Since we're not feature complete e.g. no tref, no SVG fonts etc, we've chosen to leave them unset.
Asked on public-svg-wg about fixing the test suite test:

http://lists.w3.org/Archives/Public/public-svg-wg/2011JanMar/0061.html
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 984778
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.