form post with taget doesn't submit data correctly for hidden value

RESOLVED DUPLICATE of bug 41241

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 41241
18 years ago
18 years ago

People

(Reporter: Phill, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (Win95; I)
BuildID:    M17 for Win95 and Linux

When the following code is used the values are not submitted, nothing appears to 
be wrong with the code it works with NS4.x and IE

<FORM METHOD=POST ACTION=Reports/StaffMember_TT.asp TARGET=stafftt><INPUT 
TYPE=HIDDEN NAME="staff_id" VALUE="AE"><INPUT TYPE=SUBMIT 
VALUE=Timetable&nbsp;for&nbsp;Ainslie&nbsp;Ellis></FORM>

<FORM METHOD=POST ACTION=Reports/Subject_TT.asp TARGET=subjecttt><INPUT 
TYPE=HIDDEN NAME="Subjectname" VALUE="CPE1001"><INPUT TYPE=SUBMIT 
VALUE="Timetable for OO Programming in Java">
</FORM>

<FORM METHOD=POST ACTION=Reports/course_TT.asp TARGET=cousett><INPUT TYPE=HIDDEN 
NAME="course_id" VALUE="1"><INPUT TYPE=SUBMIT 
VALUE="Timetable&nbsp;for&nbsp;Bachelor of Network Computing 1st Year"></FORM>
<FORM METHOD=POST ACTION=Reports/room_TT.asp TARGET=roomtt>
<INPUT TYPE=HIDDEN NAME="Room_id" VALUE="FBLCK"><INPUT TYPE=SUBMIT 
VALUE=Timetable&nbsp;for&nbsp;FBLCK>
</FORM>

Reproducible: Always
Steps to Reproduce:
1. run the included code
2.
3.

Actual Results:  Values were not submitted to the server.			
			

Expected Results:  Values should have been submitted to the server		
					

<FORM METHOD=POST ACTION=Reports/StaffMember_TT.asp TARGET=stafftt><INPUT 
TYPE=HIDDEN NAME="staff_id" VALUE="AE"><INPUT TYPE=SUBMIT 
VALUE=Timetable&nbsp;for&nbsp;Ainslie&nbsp;Ellis></FORM>
<FORM METHOD=POST ACTION=Reports/Subject_TT.asp TARGET=subjecttt><INPUT 
TYPE=HIDDEN NAME="Subjectname" VALUE="CPE1001"><INPUT TYPE=SUBMIT 
VALUE="Timetable for OO Programming in Java">
</FORM>

<FORM METHOD=POST ACTION=Reports/course_TT.asp TARGET=cousett><INPUT TYPE=HIDDEN 
NAME="course_id" VALUE="1"><INPUT TYPE=SUBMIT 
VALUE="Timetable&nbsp;for&nbsp;Bachelor of Network Computing 1st Year"></FORM>
<FORM METHOD=POST ACTION=Reports/room_TT.asp TARGET=roomtt>
<INPUT TYPE=HIDDEN NAME="Room_id" VALUE="FBLCK"><INPUT TYPE=SUBMIT 
VALUE=Timetable&nbsp;for&nbsp;FBLCK>
</FORM>

Comment 1

18 years ago
Reporter: You are using an old build (M17). Could you try this on a more recent 
build? I tried another form with a hidden value and it worked, but I didn't try 
the above code. Could you kindly put it into an attachment for us all? :)

Comment 2

18 years ago
Hidden values work fine on:
- LinuxRH62 2000-09-05-08-M18 Commercial
- Win98     2000-09-05-08-M18 Commercial
- MacOS86   2000-09-05-08-M18 Mozilla

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

18 years ago
Actually, it has to do with hidden values where the for post has a target - 
reopening
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 41241 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

18 years ago
Summary: Hidden values are not submitted → form post with taget doesn't submit data correctly for hidden value

Comment 5

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
You need to log in before you can comment on or make changes to this bug.