Closed Bug 512671 Opened 10 years ago Closed 10 years ago

libnkgnomevfs is built with Firefox in libxul-sdk builds

Categories

(Firefox Build System :: General, defect, minor)

All
Linux
defect
Not set
minor

Tracking

(status1.9.2 .5-fixed)

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- .5-fixed

People

(Reporter: wolfiR, Assigned: wolfiR)

References

Details

Attachments

(1 file, 1 obsolete file)

libnkgnomevfs is built with Firefox-on-xulrunner although it's already part of xulrunner itself. That's because it only depends on the MOZ_EXTENSIONS in configure.in.
Attached patch possible patch (obsolete) — Splinter Review
Assignee: nobody → mozilla
I think it's a duplicate of bug 423129, though the present one is more specific.
Attachment #396704 - Flags: review?(ted.mielczarek)
I would mark this as part of the other if bugzilla would support it.
Duplicate of this bug: 420255
Comment on attachment 396704 [details] [diff] [review]
possible patch

I don't want a warning here, since everybody building FF-on-XR will see it. Just make it silently do the right thing.
Attachment #396704 - Flags: review?(ted.mielczarek) → review-
Attached patch patch #2Splinter Review
Remove gnomevfs _and_ gio from extensions for libxul based apps.
No warning or output anymore.
Attachment #396704 - Attachment is obsolete: true
Attachment #400997 - Flags: review?(ted.mielczarek)
Comment on attachment 400997 [details] [diff] [review]
patch #2

Convention in configure.in is to use "test -n", not "test ! -z. r=me with that change.
Attachment #400997 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/cd56524d27be
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Comment on attachment 400997 [details] [diff] [review]
patch #2

Requesting approval for 1.9.2 as it's a simple thing and shrinks the patch queue of Linux distros.
The 1.9.2 will skip the gio part.
Attachment #400997 - Flags: approval1.9.2?
Asking wanted-1.9.2 as I'm wondering why that doesn't get approved or denied since weeks.
Flags: wanted1.9.2?
Attachment #400997 - Flags: approval1.9.2? → approval1.9.2.2?
Flags: in-testsuite-
Comment on attachment 400997 [details] [diff] [review]
patch #2

We should take this for 1.9.2.3
Attachment #400997 - Flags: approval1.9.2.2? → approval1.9.2.3?
Comment on attachment 400997 [details] [diff] [review]
patch #2

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Attachment #400997 - Flags: approval1.9.2.4? → approval1.9.2.5+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.