Closed Bug 512853 Opened 11 years ago Closed 11 years ago

fix parseKeyValuePairs to support values containing =, use iframe type="content" for the about:crashes submit form

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta1-fixed
status1.9.1 --- .4-fixed

People

(Reporter: ted, Assigned: ted)

References

()

Details

(Keywords: verified1.9.1)

Attachments

(1 file)

Currently we use string.split('=',2), which apparently truncates if it encounters more than 1 =. We should fix that.
Duplicate of this bug: 512855
Summary: fix parseKeyValuePairs to support values containing = → fix parseKeyValuePairs to support values containing =, use iframe type="content" for the about:crashes submit form
Attached patch fix both issuesSplinter Review
Fixes both issues, add a test for the "data containing =" case.
Attachment #397837 - Flags: review?(dtownsend)
Attachment #397837 - Flags: review?(dtownsend) → review+
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/5d7792125ab4
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Verified fixed for 1.9.1 in source.
Keywords: verified1.9.1
You need to log in before you can comment on or make changes to this bug.